summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-22 21:54:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-22 21:54:00 +0000
commit5143df4c4950bfbdbb9dfbabe519e1d5903c56b6 (patch)
treef1a7fa29f5c14139388b132e5288b96c08c8620e /net-libs/gssdp/gssdp-0.9.2.ebuild
parentnew init script. thx #333925 (diff)
downloadhistorical-5143df4c4950bfbdbb9dfbabe519e1d5903c56b6.tar.gz
historical-5143df4c4950bfbdbb9dfbabe519e1d5903c56b6.tar.bz2
historical-5143df4c4950bfbdbb9dfbabe519e1d5903c56b6.zip
Version bump. Required for recent rygel releases, with permission from herd.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'net-libs/gssdp/gssdp-0.9.2.ebuild')
-rw-r--r--net-libs/gssdp/gssdp-0.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/gssdp/gssdp-0.9.2.ebuild b/net-libs/gssdp/gssdp-0.9.2.ebuild
new file mode 100644
index 000000000000..829e82fc4c83
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/gssdp-0.9.2.ebuild,v 1.1 2011/02/22 21:54:00 eva Exp $
+
+EAPI=3
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP."
+HOMEPAGE="http://gupnp.org/"
+SRC_URI="http://gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND=">=dev-libs/glib-2.22:2
+ >=net-libs/libsoup-2.26.1:2.4[introspection?]
+ gtk? ( >=x11-libs/gtk+-2.12:2 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_with gtk) \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}