summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-01-24 22:27:18 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-01-24 22:27:18 +0000
commit77a6744a09188dc821bc31d8f74ba73c85187255 (patch)
tree38d4acc1d7e37a541efb72389ec36da98db82e6e /net-libs/openslp/openslp-1.2.1-r2.ebuild
parentFinally mask media-fonts/gnu-gs-fonts-* for last-riting, ending (diff)
downloadhistorical-77a6744a09188dc821bc31d8f74ba73c85187255.tar.gz
historical-77a6744a09188dc821bc31d8f74ba73c85187255.tar.bz2
historical-77a6744a09188dc821bc31d8f74ba73c85187255.zip
Fix buffer overflow, bug 329039. Thanks to Joseph Yasi for the patch.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'net-libs/openslp/openslp-1.2.1-r2.ebuild')
-rw-r--r--net-libs/openslp/openslp-1.2.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/openslp/openslp-1.2.1-r2.ebuild b/net-libs/openslp/openslp-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..a875e89c3275
--- /dev/null
+++ b/net-libs/openslp/openslp-1.2.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-1.2.1-r2.ebuild,v 1.1 2012/01/24 22:27:18 dilfridge Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+HOMEPAGE="http://www.openslp.org/"
+SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-fbsd.patch
+ epatch "${FILESDIR}"/${P}-fixoverflow.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf || die
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
+ rm -rf "${D}"/usr/doc
+ dohtml -r .
+ newinitd "${FILESDIR}"/slpd-init slpd
+}