summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-27 17:29:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-27 17:29:41 +0000
commitb2cf95888567deea1cffe085e0f06bae5a348f17 (patch)
tree7e656bc40b6ffa4a6972c6bb4309d0bb91e062f4 /net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild
parentAdd <folks-0.3 blocker for empathy-2.32. Bump to 2.33.2, uses new telepathy-l... (diff)
downloadhistorical-b2cf95888567deea1cffe085e0f06bae5a348f17.tar.gz
historical-b2cf95888567deea1cffe085e0f06bae5a348f17.tar.bz2
historical-b2cf95888567deea1cffe085e0f06bae5a348f17.zip
Version bump. Disable static library and remove useless files from python module installation.
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild')
-rw-r--r--net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild b/net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild
new file mode 100644
index 000000000000..26bb26cc63d8
--- /dev/null
+++ b/net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/telepathy-farsight-0.0.16.ebuild,v 1.1 2011/02/27 17:29:41 eva Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit python
+
+DESCRIPTION="Farsight connection manager for the Telepathy framework"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="python"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ >=net-libs/telepathy-glib-0.13.4
+ >=net-libs/farsight2-0.0.17
+ python? (
+ >=dev-python/pygobject-2.12.0
+ >=dev-python/gst-python-0.10.10 )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use python; then
+ python_convert_shebangs -r 2 .
+ fi
+}
+
+src_configure() {
+ econf $(use_enable python) --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ python_clean_installation_image
+ dodoc NEWS ChangeLog || die
+}