summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-03-08 15:20:27 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-03-08 15:20:27 +0000
commit30e3cf94715e48a78c1246451b880433e9639c8b (patch)
treeae2a83313e8afbec40841d93f3b2bec01228762a /net-libs/telepathy-glib
parentStable on ppc, see bug #212666. (diff)
downloadhistorical-30e3cf94715e48a78c1246451b880433e9639c8b.tar.gz
historical-30e3cf94715e48a78c1246451b880433e9639c8b.tar.bz2
historical-30e3cf94715e48a78c1246451b880433e9639c8b.zip
Version bump.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog8
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.7.5.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 064a1e75a5ab..b0913c8fe765 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.12 2008/02/29 07:25:59 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.13 2008/03/08 15:16:35 coldwind Exp $
+
+*telepathy-glib-0.7.5 (08 Mar 2008)
+
+ 08 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +telepathy-glib-0.7.5.ebuild:
+ Version bump.
29 Feb 2008; Mart Raudsepp <leio@gentoo.org> telepathy-glib-0.7.3.ebuild:
Install README and NEWS docs
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.7.5.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.7.5.ebuild
new file mode 100644
index 000000000000..320a672ce1f0
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.7.5.ebuild,v 1.1 2008/03/08 15:16:35 coldwind Exp $
+
+DESCRIPTION="GLib binding for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=dev-libs/dbus-glib-0.73
+ >=dev-lang/python-2.3"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21
+ doc? ( >=dev-util/gtk-doc-1.5 )"
+
+src_compile() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable debug) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}