summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-06-10 21:45:05 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-06-10 21:45:05 +0000
commitc3cdf757bc163de4ea74ebb15cebe1dd6a8e6045 (patch)
treed62233fd5b9901ed7ec3d996e1b78a8ab86445e4 /net-libs/udns/udns-0.0.9.ebuild
parentInitial commit, ebuild by Simon Arlott, see bug #222741. (diff)
downloadhistorical-c3cdf757bc163de4ea74ebb15cebe1dd6a8e6045.tar.gz
historical-c3cdf757bc163de4ea74ebb15cebe1dd6a8e6045.tar.bz2
historical-c3cdf757bc163de4ea74ebb15cebe1dd6a8e6045.zip
Improve ebuild, changes by Thomas Anderson (gentoofan23).
Package-Manager: portage-2.1.5.4
Diffstat (limited to 'net-libs/udns/udns-0.0.9.ebuild')
-rw-r--r--net-libs/udns/udns-0.0.9.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/net-libs/udns/udns-0.0.9.ebuild b/net-libs/udns/udns-0.0.9.ebuild
index 1f36f4dc504f..ef0c4f35e76e 100644
--- a/net-libs/udns/udns-0.0.9.ebuild
+++ b/net-libs/udns/udns-0.0.9.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/udns-0.0.9.ebuild,v 1.1 2008/06/10 21:34:09 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/udns/udns-0.0.9.ebuild,v 1.2 2008/06/10 21:45:05 nelchael Exp $
-inherit eutils multilib
+inherit multilib
-DESCRIPTION="async-capable DNS stub resolver library"
+DESCRIPTION="Async-capable DNS stub resolver library"
HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
SRC_URI="http://www.corpit.ru/mjt/udns/${P/-/_}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="ipv6 static"
# Yes, this doesn't depend on any other library beside "system" set
DEPEND=""
@@ -19,16 +19,21 @@ DEPEND=""
src_compile() {
# Uses non-standard configure script, econf doesn't work
- ./configure || die "configure failed"
- emake staticlib sharedlib || die "make failed"
+ ./configure $(use_enable ipv6) || die "Configure failed"
+ emake sharedlib || die "Shared library compilation failed"
+ if use static; then
+ emake staticlib || die "Static library compilation failed"
+ fi
}
src_install() {
dolib.so libudns.so.0 || die "dolib.so failed"
- dolib.a libudns.a || die "dolib.a failed"
dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so" || die "dosym failed"
+ if use static; then
+ dolib.a libudns.a || die "dolib.a failed"
+ fi
insinto /usr/include
doins udns.h || die "doins failed"