summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-28 10:05:19 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-28 10:05:19 +0000
commit2da56ca3b4bb5858c5cf2a8ac231bf88403251b5 (patch)
tree7db32e75a4db989500f7fe360b223622edc8a460 /net-libs
parentadd gnutls (diff)
downloadhistorical-2da56ca3b4bb5858c5cf2a8ac231bf88403251b5.tar.gz
historical-2da56ca3b4bb5858c5cf2a8ac231bf88403251b5.tar.bz2
historical-2da56ca3b4bb5858c5cf2a8ac231bf88403251b5.zip
add openssl and gnutls deps
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog6
-rw-r--r--net-libs/libsoup/Manifest5
-rw-r--r--net-libs/libsoup/files/libsoup-1.99.26-with_ssl.patch94
-rw-r--r--net-libs/libsoup/libsoup-1.99.26.ebuild40
4 files changed, 126 insertions, 19 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index 96bfe326b152..7e5efca26b11 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libsoup
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.9 2003/09/24 14:28:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.10 2003/09/28 10:05:14 liquidx Exp $
+
+ 28 Sep 2003; Alastair Tse <liquidx@gentoo.org> libsoup-1.99.26.ebuild,
+ files/libsoup-1.99.26-with_ssl.patch:
+ add patch to switch between openssl and gnutls
*libsoup-1.99.26 (24 Sep 2003)
diff --git a/net-libs/libsoup/Manifest b/net-libs/libsoup/Manifest
index cfe3eef76888..49a4f5c8ba54 100644
--- a/net-libs/libsoup/Manifest
+++ b/net-libs/libsoup/Manifest
@@ -1,8 +1,9 @@
-MD5 bc5cab157cc104b5992c589e56d37975 ChangeLog 1386
+MD5 0c7327e07327040247f3730368f9a203 ChangeLog 1550
MD5 f512ef86c6c90d0192f989c609ab7f91 libsoup-1.99.22.ebuild 840
MD5 1185b3561a784c1655c1f79b6cc3f4f0 libsoup-1.99.23.ebuild 845
-MD5 d7070fe1d6359ec8843e9f6dfb24b3ec libsoup-1.99.26.ebuild 846
+MD5 b516d54fc74d8c12d4280761815f6ee5 libsoup-1.99.26.ebuild 1176
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 4ed2ee4ad5a6e2b7041129cabbcb78d2 files/digest-libsoup-1.99.22 68
MD5 f45a9e30ed0c538e279fc46a19c88bbf files/digest-libsoup-1.99.23 68
MD5 ceb6a90e8f49bead5b674b989de37ad7 files/digest-libsoup-1.99.26 68
+MD5 09a0c3f27613d90ffeb8abb875598ace files/libsoup-1.99.26-with_ssl.patch 2861
diff --git a/net-libs/libsoup/files/libsoup-1.99.26-with_ssl.patch b/net-libs/libsoup/files/libsoup-1.99.26-with_ssl.patch
new file mode 100644
index 000000000000..61486d56f582
--- /dev/null
+++ b/net-libs/libsoup/files/libsoup-1.99.26-with_ssl.patch
@@ -0,0 +1,94 @@
+--- libsoup-1.99.26/configure.in 2003-09-12 22:07:05.000000000 +0100
++++ libsoup-1.99.26/configure.in 2003-09-28 09:55:18.779887808 +0100
+@@ -177,9 +177,10 @@
+ dnl *** SSL Library checks (GnuTLS, Mozilla NSS, or OpenSSL) ***
+ dnl ************************************************************
+
+-AC_ARG_ENABLE(ssl,
+- [ --enable-ssl Turn on Secure Sockets Layer support [default=yes]],,
+- enable_ssl=yes)
++AC_ARG_WITH(ssl,
++ [ --with-ssl=yes|no|gnutls|openssl Specify Secure Socket Layer Support and Implementation Preference (default=yes)],
++ [with_ssl=$withval],
++ [with_ssl=yes])
+
+ dnl NSS AC_ARG_WITH(nspr-includes,
+ dnl NSS [ --with-nspr-includes Specify location of Netscape Portable Runtime headers],
+@@ -242,43 +243,44 @@
+ enable_openssl="no"
+ dnl NSS enable_nss="no"
+
+-if test "x$enable_ssl" = xyes; then
++if test "x$with_ssl" != xno; then
+ found_ssl=
+
+ ###
+ ### Check for GnuTLS
+ ###
+- save_CPPFLAGS=$CPPFLAGS
+- CPPFLAGS="$CPPFLAGS $gnutls_inc_prefix"
+- AC_CHECK_HEADERS(gnutls/gnutls.h,
++ if test "x$with_ssl" != "xopenssl"; then
++ save_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS="$CPPFLAGS $gnutls_inc_prefix"
++ AC_CHECK_HEADERS(gnutls/gnutls.h,
+ [enable_gnutls="yes"],
+ [enable_gnutls="no"; break])
+
+- if test "x$enable_gnutls" = xyes; then
+- if test "x$enable_static_ssl" = "xyes"; then
+- GNUTLS_LIBS="$gnutls_prefix/libgnutls.a $gnutls_prefix/libgcrypt.a"
++ if test "x$enable_gnutls" = xyes; then
++ if test "x$enable_static_ssl" = "xyes"; then
++ GNUTLS_LIBS="$gnutls_prefix/libgnutls.a $gnutls_prefix/libgcrypt.a"
++ else
++ GNUTLS_LIBS="-L$gnutls_prefix -lgnutls -lgcrypt"
++ fi
++ GNUTLS_CFLAGS=$CPPFLAGS
++ AC_DEFINE(HAVE_GNUTLS, 1,
++ [Defined if you are using GnuTLS for SSL support])
++ found_ssl=yes
+ else
+- GNUTLS_LIBS="-L$gnutls_prefix -lgnutls -lgcrypt"
++ GNUTLS_LIBS=
++ GNUTLS_CFLAGS=
+ fi
+- GNUTLS_CFLAGS=$CPPFLAGS
+- AC_DEFINE(HAVE_GNUTLS, 1,
+- [Defined if you are using GnuTLS for SSL support])
+- found_ssl=yes
+- else
+- GNUTLS_LIBS=
+- GNUTLS_CFLAGS=
+- fi
+-
+- AC_SUBST(GNUTLS_CFLAGS)
+- AC_SUBST(GNUTLS_LIBS)
+- CPPFLAGS=$save_CPPFLAGS
+
+- AM_CONDITIONAL(BUILD_PROXY, false)
++ AC_SUBST(GNUTLS_CFLAGS)
++ AC_SUBST(GNUTLS_LIBS)
++ CPPFLAGS=$save_CPPFLAGS
+
++ AM_CONDITIONAL(BUILD_PROXY, false)
++ fi
+ ###
+ ### Check for OpenSSL
+ ###
+- if test "x$found_ssl" != "xyes"; then
++ if test "x$found_ssl" != "xyes" -a "x$with_ssl" != "xgnutls"; then
+ PKG_CHECK_MODULES(OPENSSL, openssl, enable_openssl=yes, [
+ save_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $openssl_inc_prefix"
+@@ -311,6 +313,10 @@
+ AC_SUBST(OPENSSL_CFLAGS)
+ AC_SUBST(OPENSSL_LIBS)
+ fi
++
++ if test "x$enable_openssl" = "xno" -a "x$enable_gnutls" = "xno"; then
++ AC_MSG_ERROR("Cannot find GnuTLS or OpenSSL")
++ fi
+
+ dnl NSS ###
+ dnl NSS ### Check for Mozilla NSS
diff --git a/net-libs/libsoup/libsoup-1.99.26.ebuild b/net-libs/libsoup/libsoup-1.99.26.ebuild
index 45ed79ba2c1e..6fec85d65a4c 100644
--- a/net-libs/libsoup/libsoup-1.99.26.ebuild
+++ b/net-libs/libsoup/libsoup-1.99.26.ebuild
@@ -1,40 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-1.99.26.ebuild,v 1.1 2003/09/24 14:28:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-1.99.26.ebuild,v 1.2 2003/09/28 10:05:14 liquidx Exp $
-#IUSE="ssl"
-IUSE=""
inherit gnome.org libtool
-S="${WORKDIR}/${P}"
DESCRIPTION="Soup is a SOAP implementation"
HOMEPAGE="http://www.gnome.org/"
-SLOT="2"
+IUSE="gnutls"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa"
+
RDEPEND=">=dev-libs/glib-2.0
- dev-libs/openssl"
+ !gnutls? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )"
+
DEPEND=">=dev-util/pkgconfig-0.12.0
dev-libs/popt
${RDEPEND}"
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa"
+src_unpack() {
+ unpack ${A}
+ # added --with-ssl=openssl|gnutls to choose between the two.
+ epatch ${FILESDIR}/${P}-with_ssl.patch
+ cd ${S}; aclocal; automake; autoconf
+}
src_compile() {
- elibtoolize
-
- local myconf=""
-
+ local myconf
+ elibtoolize
+
# current build system deems ssl as NOT AN OPTION.
# use ssl && myconf="--enable-ssl --enable-openssl"
+ use gnutls \
+ && myconf="${myconf} --with-ssl=gnutls" \
+ || myconf="${myconf} --with-ssl=openssl"
- econf ${myconf} || die
- emake || die
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- einstall || die
+ einstall || die "install failed"
dodoc AUTHORS COPYING* ChangeLog README* TODO
}