summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-08-06 20:09:38 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-08-06 20:09:38 +0000
commitf9165096caaa4e7fba0666978e1f1ba2449038ce (patch)
treeedaf119e4bab3cf649a1525e285cb09b6b0d878b /net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild
parentremoving libprelude as it doesn't cause any trouble on OSX Tiger (diff)
downloadhistorical-f9165096caaa4e7fba0666978e1f1ba2449038ce.tar.gz
historical-f9165096caaa4e7fba0666978e1f1ba2449038ce.tar.bz2
historical-f9165096caaa4e7fba0666978e1f1ba2449038ce.zip
New version
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild')
-rw-r--r--net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild b/net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild
new file mode 100644
index 000000000000..5a6c915306df
--- /dev/null
+++ b/net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cmd5checkpw/cmd5checkpw-0.30.ebuild,v 1.1 2005/08/06 20:09:37 hansmi Exp $
+
+inherit eutils toolchain-funcs fixheadtails
+
+MY_VER="030"
+
+DESCRIPTION="A checkpassword compatible authentication program that used CRAM-MD5 authentication mode."
+SRC_URI="http://www.fehcom.de/qmail/auth/${PN}-${MY_VER}_tgz.bin"
+HOMEPAGE="http://www.fehcom.de/qmail/smtpauth.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+douser() {
+ enewuser cmd5checkpw 212 /bin/false /dev/null bin
+}
+
+pkg_preinst() {
+ douser
+}
+
+pkg_setup() {
+ douser
+ echo
+ ewarn "this version is in NO WAY COMPATIBLE with cmd5checkpw-0.2x"
+ ewarn "it actually receives the authentication credentials"
+ ewarn "in a different order then the old implementation"
+ ewarn "see bug #100693 for details"
+ ewarn "this version IS needed by >=qmail-1.03-r16"
+ echo
+}
+
+src_unpack() {
+ tar -xzf "${DISTDIR}/${PN}-${MY_VER}_tgz.bin" -C "${WORKDIR}"
+ cd "${S}"
+ epatch ${FILESDIR}/euid_${MY_VER}.diff || die
+ epatch ${FILESDIR}/reloc.diff || die
+ ht_fix_file ${S}/Makefile
+}
+
+src_compile() {
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:-c -g -Wall -O3:${CFLAGS}:" \
+ -e "s:cp cmd5checkpw /bin/:cp cmd5checkpw \${D}/bin/:" \
+ -e "s:cp cmd5checkpw.8 /usr/man/man8/:cp cmd5checkpw.8 \${D}/usr/share/man/man8/:" \
+ -e "/^LDFLAGS/ a LDFLAGS+='-Wl,-z,now'" \
+ < Makefile.orig > Makefile
+ cd ${S}
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ make || die
+}
+
+src_install() {
+ dodir /etc /bin /usr/share/man/man8
+ insinto /etc
+ doins ${FILESDIR}/poppasswd
+ exeinto /bin
+ doexe cmd5checkpw
+ doman cmd5checkpw.8
+ fowners cmd5checkpw /etc/poppasswd /bin/cmd5checkpw
+ fperms 400 /etc/poppasswd
+ fperms u+s /bin/cmd5checkpw
+}
+
+pkg_postinst() {
+ chmod 400 ${ROOT}/etc/poppasswd
+ chown cmd5checkpw ${ROOT}/etc/poppasswd
+}