summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-03-26 23:51:52 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-03-26 23:51:52 +0000
commit7079fef31d9d55fb2df2bfd2ceb872a72063144f (patch)
tree438cc5ea38ef0b9c789748418b9fc366c24e070a /net-mail/dbmail/dbmail-2.2.4.ebuild
parentAdded net-mail/dbmail:sieve (diff)
downloadhistorical-7079fef31d9d55fb2df2bfd2ceb872a72063144f.tar.gz
historical-7079fef31d9d55fb2df2bfd2ceb872a72063144f.tar.bz2
historical-7079fef31d9d55fb2df2bfd2ceb872a72063144f.zip
Initial import. Ebuild by several people collaborating in bug #22331 (yes, _that_ old!), based on ebuild written by Chris Johnson <cmjohn at mail.utexas.edu>.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'net-mail/dbmail/dbmail-2.2.4.ebuild')
-rw-r--r--net-mail/dbmail/dbmail-2.2.4.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/net-mail/dbmail/dbmail-2.2.4.ebuild b/net-mail/dbmail/dbmail-2.2.4.ebuild
new file mode 100644
index 000000000000..51a3c8369056
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.4.ebuild,v 1.1 2007/03/26 23:51:52 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+}