summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2001-12-05 02:33:04 +0000
committerGeert Bevin <gbevin@gentoo.org>2001-12-05 02:33:04 +0000
commit8e1db567e5fe16ef274be8fc81539e8fc5e48804 (patch)
tree056627331e1f59958f1f7e8bb286a3a26d6bfe7d /net-mail/dot-forward
parentUpgraded to new version and integrate with startup scripts. (diff)
downloadhistorical-8e1db567e5fe16ef274be8fc81539e8fc5e48804.tar.gz
historical-8e1db567e5fe16ef274be8fc81539e8fc5e48804.tar.bz2
historical-8e1db567e5fe16ef274be8fc81539e8fc5e48804.zip
Reviewed entire qmail installation since the installation was broken.
It's now installed exactly according to what's explained in the qmail howto v2. It uses daemontools for service launching. To start/stop/reload, there is an additional script /var/qmail/bin/qmail-control that can be used instead of the general svscan startup file.
Diffstat (limited to 'net-mail/dot-forward')
-rw-r--r--net-mail/dot-forward/dot-forward-0.71.ebuild52
-rw-r--r--net-mail/dot-forward/files/digest-dot-forward-0.711
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/dot-forward/dot-forward-0.71.ebuild b/net-mail/dot-forward/dot-forward-0.71.ebuild
new file mode 100644
index 000000000000..d5025022c0c0
--- /dev/null
+++ b/net-mail/dot-forward/dot-forward-0.71.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dot-forward/dot-forward-0.71.ebuild,v 1.1 2001/12/05 02:33:04 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Dot-forward reads sendmail's .forward files under qmail."
+HOMEPAGE="http://cr.yp.to/dot-forward.html"
+
+SRC_URI="http://cr.yp.to/software/dot-forward-0.71.tar.gz"
+
+DEPEND="virtual/glibc
+ sys-apps/groff"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+
+}
+
+src_compile() {
+
+ cd ${S}
+
+ emake it || die
+}
+
+
+
+src_install() {
+
+ into /usr
+ dodoc BLURB CHANGES FILES INSTALL README SYSDEPS TARGETS THANKS
+ dodoc TODO VERSION
+
+ insopts -o root -g qmail -m 755
+ insinto /var/qmail/bin
+ doins dot-forward
+
+ into /usr
+ for i in *.1
+ do
+ doman $i
+ done
+
+}
diff --git a/net-mail/dot-forward/files/digest-dot-forward-0.71 b/net-mail/dot-forward/files/digest-dot-forward-0.71
new file mode 100644
index 000000000000..cf6dbc6b3b0e
--- /dev/null
+++ b/net-mail/dot-forward/files/digest-dot-forward-0.71
@@ -0,0 +1 @@
+MD5 1fefd9760e4706491fb31c7511d69bed dot-forward-0.71.tar.gz 28672