summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-12-21 22:19:56 +0000
committerNick Hadaway <raker@gentoo.org>2002-12-21 22:19:56 +0000
commitd61cce863555ff417d7d9851e48d208babdbfa28 (patch)
tree505b11ad2fa869b056b60b97aacdbbec2d91543b /net-mail/maildrop/maildrop-1.4.0-r1.ebuild
parentenhanced libpng depend, and added system expat support (diff)
downloadhistorical-d61cce863555ff417d7d9851e48d208babdbfa28.tar.gz
historical-d61cce863555ff417d7d9851e48d208babdbfa28.tar.bz2
historical-d61cce863555ff417d7d9851e48d208babdbfa28.zip
filtering -fomit-frame-pointer and -funroll-loops
Diffstat (limited to 'net-mail/maildrop/maildrop-1.4.0-r1.ebuild')
-rw-r--r--net-mail/maildrop/maildrop-1.4.0-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-mail/maildrop/maildrop-1.4.0-r1.ebuild b/net-mail/maildrop/maildrop-1.4.0-r1.ebuild
index 8b88c19f8723..2ea747050450 100644
--- a/net-mail/maildrop/maildrop-1.4.0-r1.ebuild
+++ b/net-mail/maildrop/maildrop-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.4.0-r1.ebuild,v 1.7 2002/12/09 04:33:14 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.4.0-r1.ebuild,v 1.8 2002/12/21 22:19:56 raker Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Mail delivery agent/filter"
@@ -16,11 +16,11 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc "
+inherit flag-o-matic
+filter-flags -funroll-loops
+filter-flags -fomit-frame-pointer
+
src_compile() {
- # These next two lines are a MUST! If tries to unroll the loops in
- # CFLAGS or CXXFLAGS maildrop will not compile :-( <lamer@gentoo.org>
- export CFLAGS="${CFLAGS/-funroll-loops/}"
- export CXXFLAGS="${CXXFLAGS/-funroll-loops/}"
./configure \
--prefix=/usr \
--with-devel \