summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-02-04 13:19:42 +0000
committerTorsten Veller <tove@gentoo.org>2005-02-04 13:19:42 +0000
commita827b10d85fc71d6f944e49480c2306a5b7483ee (patch)
tree304b49af51f3c1d27d3fc194ac30c56f46e17c0c /net-mail/mairix/mairix-0.15.2.ebuild
parentRevision bump for bug 78922; fixes a few equery completion bugs. (diff)
downloadhistorical-a827b10d85fc71d6f944e49480c2306a5b7483ee.tar.gz
historical-a827b10d85fc71d6f944e49480c2306a5b7483ee.tar.bz2
historical-a827b10d85fc71d6f944e49480c2306a5b7483ee.zip
Version bump.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'net-mail/mairix/mairix-0.15.2.ebuild')
-rw-r--r--net-mail/mairix/mairix-0.15.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-mail/mairix/mairix-0.15.2.ebuild b/net-mail/mairix/mairix-0.15.2.ebuild
new file mode 100644
index 000000000000..005ec8aab927
--- /dev/null
+++ b/net-mail/mairix/mairix-0.15.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mairix/mairix-0.15.2.ebuild,v 1.1 2005/02/04 13:19:42 tove Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Indexes and searches Maildir/MH folders"
+HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
+SRC_URI="http://www.rpcurnow.force9.co.uk/mairix/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ >=sys-apps/texinfo-4.2
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ # econf would fail with unknown options.
+ # Now it only prints "Unrecognized option".
+ sed -i -e "/^\s*bad_options=yes/d" ${S}/configure || die "sed failed."
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf || die "configure failed."
+
+ emake all mairix.info || die "make failed."
+}
+
+src_install() {
+ dobin mairix || die "dobin failed."
+ doinfo mairix.info || die "doinfo failed."
+ dodoc NEWS README mairix.txt || die "dodoc failed."
+}