summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-05-12 01:40:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-05-12 01:40:28 +0000
commitd9303ad307307544caf74f21596a6206b87ee289 (patch)
tree3f22027e6bdb841b3d912a194d2676ef0b4ca88a /net-mail/metamail/metamail-2.7.45.3.ebuild
parentAdded s390 keywords (diff)
downloadhistorical-d9303ad307307544caf74f21596a6206b87ee289.tar.gz
historical-d9303ad307307544caf74f21596a6206b87ee289.tar.bz2
historical-d9303ad307307544caf74f21596a6206b87ee289.zip
autoreconf wasn't working, to fix bug #41095. Instead, switching to the documented hacky way around this issue, which is to try make again when it fails the first time
Diffstat (limited to 'net-mail/metamail/metamail-2.7.45.3.ebuild')
-rw-r--r--net-mail/metamail/metamail-2.7.45.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-mail/metamail/metamail-2.7.45.3.ebuild b/net-mail/metamail/metamail-2.7.45.3.ebuild
index f6cdfbed4bef..66d6fef91034 100644
--- a/net-mail/metamail/metamail-2.7.45.3.ebuild
+++ b/net-mail/metamail/metamail-2.7.45.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/metamail/metamail-2.7.45.3.ebuild,v 1.2 2004/05/11 22:55:13 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/metamail/metamail-2.7.45.3.ebuild,v 1.3 2004/05/12 01:40:28 seemant Exp $
inherit eutils
@@ -23,13 +23,16 @@ DEPEND="sys-libs/ncurses
src_unpack() {
unpack ${A}
- export WANT_AUTOCONF=2.1
cd ${S}
epatch ${WORKDIR}/metamail_${MY_PV}.diff
- autoreconf
chmod +x ${S}/configure
}
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ econf || die
+ emake || emake || die
+}
src_install () {
make DESTDIR=${D} install || die
dodoc COPYING CREDITS README