summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-07-08 17:31:53 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-07-08 17:31:53 +0000
commit1d54044d105308698d1531ee00e2e3a2b60d365c (patch)
treeaf9be6aea639fd3e2ed552db298e756a7c0ecde2 /net-mail/nail
parentadded nt which is a gtk based download manager for X. Works great with galeon... (diff)
downloadhistorical-1d54044d105308698d1531ee00e2e3a2b60d365c.tar.gz
historical-1d54044d105308698d1531ee00e2e3a2b60d365c.tar.bz2
historical-1d54044d105308698d1531ee00e2e3a2b60d365c.zip
Added sym links and changed /etc/nail.rc file to use smtp by default.
Diffstat (limited to 'net-mail/nail')
-rw-r--r--net-mail/nail/nail-9.27.ebuild28
1 files changed, 24 insertions, 4 deletions
diff --git a/net-mail/nail/nail-9.27.ebuild b/net-mail/nail/nail-9.27.ebuild
index 52f7b90eaf85..167dd80644e2 100644
--- a/net-mail/nail/nail-9.27.ebuild
+++ b/net-mail/nail/nail-9.27.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Grant Goodyear <g2boojum@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/nail/nail-9.27.ebuild,v 1.1 2001/07/06 16:12:47 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/nail/nail-9.27.ebuild,v 1.2 2001/07/08 17:31:53 g2boojum Exp $
#Remeber to add the proper Author line, above. Don't worry about the fourth line;
#it'll get automatically fixed when the ebuild is checked in.
@@ -20,8 +20,7 @@ SRC_URI="http://omnibus.ruf.uni-freiburg.de/~gritter/archive/nail/${P}.tar.gz"
HOMEPAGE="http://omnibus.ruf.uni-freiburg.de/~gritter/"
#build-time dependencies
-DEPEND="virtual/glibc
- virtual/mta"
+DEPEND="virtual/glibc"
#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
#RDEPEND=""
@@ -29,7 +28,8 @@ DEPEND="virtual/glibc
src_compile() {
#the "try" command will stop the build process if the specified command fails. Prefix critical
#commands with "try"
- try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} --with-mailspool=/var/spool/mail
+ #try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} --with-mailspool=/var/spool/mail
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} --with-mailspool=~/.maildir
#Note the use of --infodir and --mandir, above. This is to make this package FHS 2.2-compliant
#(/usr/share is used for info and man now).
@@ -47,6 +47,13 @@ src_install () {
#the install part of the Makefiles. Also note that this will often
#also work for autoconf stuff (usually much more often than DESTDIR,
#which is actually quite rare.
+
+ #add smtp flag to nail.rc so that it uses smtp by default (making it
+ #essentially mailer independent
+ echo -e "\n#use smtp on the local system by default. Change" >> nail.rc
+ echo -e "#\"localhost\" to your smtp server if you use a remote" >> nail.rc
+ echo -e "#smtp server. (Delete this line to use sendmail instead)" >> nail.rc
+ echo -e "set smtp=localhost" >> nail.rc
# try make prefix=${D}/usr install
@@ -54,5 +61,18 @@ src_install () {
#again, verify the Makefiles! We don't want anything falling outside
#of ${D}.
dodoc AUTHORS COPYING I18N INSTALL README
+ dodir /bin
+ dosym /usr/bin/nail /bin/mail
+ dosym /usr/bin/nail /usr/bin/mail
+ dosym /usr/bin/nail /usr/bin/Mail
}
+pkg_postinst () {
+
+ echo -e "\nNOTE: The nail mailer does _not_ support maildir format.\n" \
+ " It is best to use nail only for outgoing mail, and\n" \
+ " really only use it for scripts that require it.\n\n" \
+ "NOTE: This build has ~/.maildir compiled in as the\n" \
+ " mail spool directory.\n"
+
+}