summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-06-16 18:18:01 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-06-16 18:18:01 +0000
commit98c0cd4ef10c52266fe4b4ac72b702a508341ca0 (patch)
treed393c2257614ffb51a0ee15bdb9e37cf95b07595 /net-mail
parentBump (diff)
downloadhistorical-98c0cd4ef10c52266fe4b4ac72b702a508341ca0.tar.gz
historical-98c0cd4ef10c52266fe4b4ac72b702a508341ca0.tar.bz2
historical-98c0cd4ef10c52266fe4b4ac72b702a508341ca0.zip
Version bump.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tmda/ChangeLog7
-rw-r--r--net-mail/tmda/files/digest-tmda-0.801
-rw-r--r--net-mail/tmda/tmda-0.80.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 20dc884cb654..edf992d9b5d5 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/tmda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.31 2003/06/04 22:05:18 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.32 2003/06/16 18:18:01 agenkin Exp $
+
+*tmda-0.80 (16 Jun 2003)
+
+ 16 Jun 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
*tmda-0.79 (04 Jun 2003)
diff --git a/net-mail/tmda/files/digest-tmda-0.80 b/net-mail/tmda/files/digest-tmda-0.80
new file mode 100644
index 000000000000..c031f2ecf420
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.80
@@ -0,0 +1 @@
+MD5 2d724818d30799391eb8ab0901347dec tmda-0.80.tgz 313671
diff --git a/net-mail/tmda/tmda-0.80.ebuild b/net-mail/tmda/tmda-0.80.ebuild
new file mode 100644
index 000000000000..81fabb3afb65
--- /dev/null
+++ b/net-mail/tmda/tmda-0.80.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.80.ebuild,v 1.1 2003/06/16 18:18:01 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.1
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html getuserinfo-vpopmail.sh printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog sample.config tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+}