summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-27 03:13:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-27 03:13:39 +0000
commitdcecd8daca948e0f7d52e74675e7884407d3d59f (patch)
treef88088c8afb9da44acdeb176d43508a00c142b34 /net-misc/atftp
parentNew ppc-development-sources version, masked just because I didn't test it enough (diff)
downloadhistorical-dcecd8daca948e0f7d52e74675e7884407d3d59f.tar.gz
historical-dcecd8daca948e0f7d52e74675e7884407d3d59f.tar.bz2
historical-dcecd8daca948e0f7d52e74675e7884407d3d59f.zip
fix init script install
Diffstat (limited to 'net-misc/atftp')
-rw-r--r--net-misc/atftp/atftp-0.7.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/net-misc/atftp/atftp-0.7.ebuild b/net-misc/atftp/atftp-0.7.ebuild
index 9458adaecef8..222089375ce3 100644
--- a/net-misc/atftp/atftp-0.7.ebuild
+++ b/net-misc/atftp/atftp-0.7.ebuild
@@ -1,42 +1,35 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.7.ebuild,v 1.2 2004/03/22 20:45:29 dholm Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.7.ebuild,v 1.3 2004/03/27 03:13:39 vapier Exp $
DESCRIPTION="Advanced TFTP implementation client/server"
HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~ppc"
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )
!virtual/tftp"
-
PROVIDE="virtual/tfp"
src_compile () {
- myconf=""
- use tcpd && myconf="${myconf} --enable-libwrap" \
- || myconf="${myconf} --disable-libwrap"
-
- econf ${myconf} || die "./configure failed"
-
- cp Makefile Makefile.orig
- sed "s:CFLAGS = -g -Wall -D_REENTRANT -O2:CFLAGS = -g -Wall -D_REENTRANT ${CFLAGS}:" Makefile.orig >Makefile
+ econf `use_enable tcpd libwrap` || die "./configure failed"
+ sed -i \
+ -e "/^CFLAGS =/s:-g::" \
+ -e "/^CFLAGS =/s:-O2::" \
+ -e "/^CFLAGS =/s:$: ${CFLAGS}:" \
+ Makefile
emake || die
}
-src_install () {
+src_install() {
einstall || die "Installation failed"
exeinto /etc/init.d
newexe ${FILESDIR}/atftp.init atftp
-
insinto /etc/conf.d
- newexe ${FILESDIR}/atftp.confd atftp
+ newins ${FILESDIR}/atftp.confd atftp
}
-