summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-02-04 18:14:35 +0000
committerCédric Krier <cedk@gentoo.org>2009-02-04 18:14:35 +0000
commit5bf890bc6eb70e8aca4e8dbb40e2a0e41e51950c (patch)
tree86d36d547718be0a3ddf4771a541a9d90d1a226b /net-misc/batmand/batmand-0.3.1.ebuild
parentBump to 0.9.4, fixes #243494. Thanks to Daniel Pielmeier. (diff)
downloadhistorical-5bf890bc6eb70e8aca4e8dbb40e2a0e41e51950c.tar.gz
historical-5bf890bc6eb70e8aca4e8dbb40e2a0e41e51950c.tar.bz2
historical-5bf890bc6eb70e8aca4e8dbb40e2a0e41e51950c.zip
Version bump
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.27-hardened-r3 i686
Diffstat (limited to 'net-misc/batmand/batmand-0.3.1.ebuild')
-rw-r--r--net-misc/batmand/batmand-0.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/batmand/batmand-0.3.1.ebuild b/net-misc/batmand/batmand-0.3.1.ebuild
new file mode 100644
index 000000000000..e9b9abd66346
--- /dev/null
+++ b/net-misc/batmand/batmand-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batmand/batmand-0.3.1.ebuild,v 1.1 2009/02/04 18:14:35 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/batmand/batman}
+DESCRIPTION="Better approach to mobile Ad-Hoc networking"
+HOMEPAGE="http://open-mesh.net/"
+SRC_URI="http://downloads.open-mesh.net/batman/stable/sources/batman/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/-j \$(NUM_CPUS)//" \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dosbin batmand
+
+ newinitd "${FILESDIR}"/batmand-init.d batmand
+ newconfd "${FILESDIR}"/batmand-conf.d batmand
+
+ doman man/*.8 || die
+
+ dodoc CHANGELOG README THANKS || die
+}