summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-10-28 22:06:35 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-10-28 22:06:35 +0000
commit53db99cd922db11b20ee85337ae1b4b8a8b79515 (patch)
tree37a838c13585b422caba6329ab09d9c7c091b7e5 /net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild
parentDon't install manpages provided by vim-core (bug #152946). (diff)
downloadhistorical-53db99cd922db11b20ee85337ae1b4b8a8b79515.tar.gz
historical-53db99cd922db11b20ee85337ae1b4b8a8b79515.tar.bz2
historical-53db99cd922db11b20ee85337ae1b4b8a8b79515.zip
Inital commit. This application is a dependency for NetworkManager.
Package-Manager: portage-2.1.2_pre3-r9
Diffstat (limited to 'net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild')
-rw-r--r--net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild b/net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild
new file mode 100644
index 000000000000..544b1f9f63d5
--- /dev/null
+++ b/net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcdbd/dhcdbd-1.14-r1.ebuild,v 1.1 2006/10/28 22:06:35 metalgod Exp $
+
+inherit eutils
+
+DESCRIPTION="DHCP D-BUS daemon (dhcdbd) controls dhclient sessions with D-BUS, stores and presents DHCP options."
+HOMEPAGE="http://people.redhat.com/~jvdias/dhcdbd"
+SRC_URI="http://people.redhat.com/~jvdias/dhcdbd/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="sys-apps/dbus
+ >=net-misc/dhcp-3.0.3-r7"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.14-fix_dhclientconf.patch
+ epatch ${FILESDIR}/${PN}-1.14-dbus_close.patch
+ # This doesn't truely enable debugging, it simply allows us to see
+ # more info about state changes, hopefully.
+ use debug && epatch "${FILESDIR}/${PN}-1.14-enable_debug.patch"
+}
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README dhcp_options.h
+ newinitd ${FILESDIR}/dhcdbd.init dhcdbd
+ newconfd ${FILESDIR}/dhcdbd.confd dhcdbd
+}