summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-09-21 20:56:16 +0000
committerMike Frysinger <vapier@gentoo.org>2002-09-21 20:56:16 +0000
commitce8f3881e4cc826fe1a21940aa7880f1de09a7b8 (patch)
tree4a24bdb7d21fce6e586ebd93bb44e8b2c6353383 /net-misc/dhcp
parentMasking cdrtools-1.11.33 pending freeze. (diff)
downloadhistorical-ce8f3881e4cc826fe1a21940aa7880f1de09a7b8.tar.gz
historical-ce8f3881e4cc826fe1a21940aa7880f1de09a7b8.tar.bz2
historical-ce8f3881e4cc826fe1a21940aa7880f1de09a7b8.zip
Added -r4 to fix #8088
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/ChangeLog8
-rw-r--r--net-misc/dhcp/dhcp-3.0-r4.ebuild91
-rw-r--r--net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch24
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0-r41
4 files changed, 123 insertions, 1 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index 28d8abbcfe44..b7b6f0ccad0d 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.7 2002/09/03 07:40:14 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.8 2002/09/21 20:55:54 vapier Exp $
+
+*dhcp-3.0-r4 (21 Sep 2002)
+
+ 21 Sep 2002; Mike Frysinger <vapier@gentoo.org> dhcp-3.0-r4.ebuild, dhclient.c-3.0-dw-cli-fix.patch, digest-dhcp-3.0-r4
+
+ Added a small patch per #8088 to fix the -nw bug (patch comes from upstream)
*dhcp-3.0-r3 (16 Jun 2002)
diff --git a/net-misc/dhcp/dhcp-3.0-r4.ebuild b/net-misc/dhcp/dhcp-3.0-r4.ebuild
new file mode 100644
index 000000000000..38d0cedbcacc
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0-r4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0-r4.ebuild,v 1.1 2002/09/21 20:56:16 vapier Exp $
+
+#This is only needed for a release with pl1 at the end.
+P="dhcp-3.0pl1"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+LICENSE="isc-dhcp"
+KEYWORDS="x86 ppc sparc sparc64"
+
+SLOT="0"
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/dhclient.c-3.0-dw-cli-fix.patch || die
+
+ cd ${S}/includes
+ cat <<- END >> site.h
+#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+#define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+#define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+ cat <<- END > site.conf
+CC = gcc ${CFLAGS}
+ETC = /etc/dhcp
+VARDB = /var/lib/dhcp
+ADMMANDIR = /usr/share/man/man8
+FFMANDIR = /usr/share/man/man5
+LIBMANDIR = /usr/share/man/man3
+END
+ ./configure --with-nsupdate || die
+ emake || die
+}
+
+src_install() {
+ dodir /var/lib/dhcp
+ touch ${D}/var/lib/dhcp/dhclient.leases
+ touch ${D}/var/lib/dhcp/dhcpd.leases
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.dhcpd dhcp
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp.rc7 dhcp
+}
diff --git a/net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch b/net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch
new file mode 100644
index 000000000000..a563778bfa2e
--- /dev/null
+++ b/net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch
@@ -0,0 +1,24 @@
+*** client/dhclient.c Wed Aug 8 10:46:14 2001
+--- client/dhclient.c.fix Sat Sep 21 12:15:21 2002
+***************
+*** 198,205 ****
+ } else if (!strcmp (argv [i], "-w")) {
+ /* do not exit if there are no broadcast interfaces. */
+ persist = 1;
+- } else if (argv [i][0] == '-') {
+- usage ();
+ } else if (!strcmp (argv [i], "-e")) {
+ struct string_list *tmp;
+ if (++i == argc)
+--- 198,203 ----
+***************
+*** 216,221 ****
+--- 214,221 ----
+ exit (0);
+ } else if (!strcmp (argv [i], "-nw")) {
+ nowait = 1;
++ } else if (argv [i][0] == '-') {
++ usage ();
+ } else {
+ struct interface_info *tmp = (struct interface_info *)0;
+ status = interface_allocate (&tmp, MDL);
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0-r4 b/net-misc/dhcp/files/digest-dhcp-3.0-r4
new file mode 100644
index 000000000000..6b2999d46c71
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0-r4
@@ -0,0 +1 @@
+MD5 85164daf66b2a46b59923750c5716fd1 dhcp-3.0pl1.tar.gz 865096