summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2004-12-25 13:06:21 +0000
committerTom Martin <slarti@gentoo.org>2004-12-25 13:06:21 +0000
commite1539f1dc7f54753b36287d860eb7eeee644828d (patch)
tree505b1b37a06f29eb6bde328e5dd24adc45ef9751 /net-misc/gsasl/gsasl-0.2.3.ebuild
parentRDEPEND on bash or zsh, since zsh is also able to read bash-completions; bug ... (diff)
downloadhistorical-e1539f1dc7f54753b36287d860eb7eeee644828d.tar.gz
historical-e1539f1dc7f54753b36287d860eb7eeee644828d.tar.bz2
historical-e1539f1dc7f54753b36287d860eb7eeee644828d.zip
Version bump -> 0.2.3, stabilise 0.2.0 on amd64.
Diffstat (limited to 'net-misc/gsasl/gsasl-0.2.3.ebuild')
-rw-r--r--net-misc/gsasl/gsasl-0.2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/gsasl/gsasl-0.2.3.ebuild b/net-misc/gsasl/gsasl-0.2.3.ebuild
new file mode 100644
index 000000000000..1b6c11d24e8b
--- /dev/null
+++ b/net-misc/gsasl/gsasl-0.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-0.2.3.ebuild,v 1.1 2004/12/25 13:06:21 slarti Exp $
+
+DESCRIPTION="The GNU SASL client, server, and library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/gsasl/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="kerberos nls static doc"
+PROVIDE="virtual/gsasl"
+DEPEND="virtual/libc
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ --enable-client \
+ --enable-server \
+ $(use_enable kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable static) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README README-alpha THANKS
+ doman doc/gsasl.1
+
+ if use doc; then
+ dodoc doc/*.{eps,ps,pdf}
+ dohtml doc/*
+ docinto examples
+ dodoc examples/*.c
+ fi
+}