summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-25 23:03:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-25 23:03:37 +0000
commitfb124f13a12f8e110499e50b6abb06e684d5fb20 (patch)
tree3455d80557ca1a9f44f4139009d1616fbab9b343 /net-misc/gsasl/gsasl-1.1.ebuild
parentEnsure jpl dynamic linking consistency. (diff)
downloadhistorical-fb124f13a12f8e110499e50b6abb06e684d5fb20.tar.gz
historical-fb124f13a12f8e110499e50b6abb06e684d5fb20.tar.bz2
historical-fb124f13a12f8e110499e50b6abb06e684d5fb20.zip
Bump to 1.1, fixes half of #263867
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'net-misc/gsasl/gsasl-1.1.ebuild')
-rw-r--r--net-misc/gsasl/gsasl-1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/gsasl/gsasl-1.1.ebuild b/net-misc/gsasl/gsasl-1.1.ebuild
new file mode 100644
index 000000000000..4dd0caa237e5
--- /dev/null
+++ b/net-misc/gsasl/gsasl-1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-1.1.ebuild,v 1.1 2009/04/25 23:03:37 patrick Exp $
+
+DESCRIPTION="The GNU SASL client, server, and library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/gsasl/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="kerberos nls static doc"
+PROVIDE="virtual/gsasl"
+DEPEND="nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ --enable-client \
+ --enable-server \
+ $(use_enable kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable static) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README README-alpha THANKS
+ doman doc/gsasl.1
+
+ if use doc; then
+ dodoc doc/*.{eps,ps,pdf}
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*.c
+ fi
+}