summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-22 19:13:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-22 19:13:26 +0000
commitab3aa012e9b4441086d58913bc69f5d22e9f18ea (patch)
treed7bf9a377cbae7013969bfe969b6984a43305ad5 /net-misc/gwget/gwget-1.0.1.ebuild
parentVersion bump #259894 by Lars (Polynomial-C). (diff)
downloadhistorical-ab3aa012e9b4441086d58913bc69f5d22e9f18ea.tar.gz
historical-ab3aa012e9b4441086d58913bc69f5d22e9f18ea.tar.bz2
historical-ab3aa012e9b4441086d58913bc69f5d22e9f18ea.zip
Bump to 1.0.1. Works with epiphany up to 2.26, port to GIO.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'net-misc/gwget/gwget-1.0.1.ebuild')
-rw-r--r--net-misc/gwget/gwget-1.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/gwget/gwget-1.0.1.ebuild b/net-misc/gwget/gwget-1.0.1.ebuild
new file mode 100644
index 000000000000..d5ab62ce84b0
--- /dev/null
+++ b/net-misc/gwget/gwget-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.1.ebuild,v 1.1 2009/02/22 19:13:26 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="GTK2 WGet Frontend"
+HOMEPAGE="http://gnome.org/projects/gwget/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="epiphany libnotify"
+
+# FIXME: dbus should be optional
+# needs patching for linguas/intltool
+RDEPEND="net-misc/wget
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.16.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ >=dev-libs/dbus-glib-0.70
+ epiphany? ( >=www-client/epiphany-1.4 )
+ libnotify? ( >=x11-libs/libnotify-0.2.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.10.4"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable epiphany epiphany-extension)
+ $(use_enable libnotify)
+ --disable-static
+ --disable-schemas-install"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove /var/lib, which is created without any reason
+ rm -rf "${D}/var"
+}