summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-05-01 06:03:48 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-05-01 06:03:48 +0000
commitfda4e94d3e2fb5e44a4d002435bec22d7fd67c42 (patch)
treebefc839c0f0465402f30e16c93f448ca7b382d65 /net-misc/gyach
parentNew package (diff)
downloadhistorical-fda4e94d3e2fb5e44a4d002435bec22d7fd67c42.tar.gz
historical-fda4e94d3e2fb5e44a4d002435bec22d7fd67c42.tar.bz2
historical-fda4e94d3e2fb5e44a4d002435bec22d7fd67c42.zip
Version bump to latest
Diffstat (limited to 'net-misc/gyach')
-rw-r--r--net-misc/gyach/ChangeLog10
-rw-r--r--net-misc/gyach/files/digest-gyach-0.7.61
-rw-r--r--net-misc/gyach/gyach-0.7.6.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/gyach/ChangeLog b/net-misc/gyach/ChangeLog
index 7f40cb1898e4..14d89e3d64a2 100644
--- a/net-misc/gyach/ChangeLog
+++ b/net-misc/gyach/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/gyach
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-#
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/ChangeLog,v 1.2 2002/05/01 06:03:48 mkennedy Exp $
+
+*gyach-0.7.6 (30 Apr 2002)
+
+ 30 Apr 2002; Matthew Kennedey <mkennedy@gentoo.org> ChangeLog,
+ gyach-0.7.6.ebuild, files/digest-gyach-0.7.6 :
+
+ Add more to docs (samples.*). Version bump to latest. Added LICENSE,
+ DEPEND fix.
*gyach-0.7.5-r1 (4 Feb 2002)
diff --git a/net-misc/gyach/files/digest-gyach-0.7.6 b/net-misc/gyach/files/digest-gyach-0.7.6
new file mode 100644
index 000000000000..a35bbf56a9e8
--- /dev/null
+++ b/net-misc/gyach/files/digest-gyach-0.7.6
@@ -0,0 +1 @@
+MD5 ec97d62cc6ea55de6185d96385670ac0 gyach-0.7.6.tar.gz 183758
diff --git a/net-misc/gyach/gyach-0.7.6.ebuild b/net-misc/gyach/gyach-0.7.6.ebuild
new file mode 100644
index 000000000000..ba745601a7d1
--- /dev/null
+++ b/net-misc/gyach/gyach-0.7.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mbkennedy@ieee.com>
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/gyach-0.7.6.ebuild,v 1.1 2002/05/01 06:03:48 mkennedy Exp $
+
+LICENSE="GPL-2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+
+DEPEND="virtual/glibc
+ >=x11-libs/gtk+-1.2.0"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}