summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-12-27 16:25:36 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-12-27 16:25:36 +0000
commit6aeb017bf4e93caaeb1233a3d330f96c713236a0 (patch)
tree0382168ce2f73ced4af3e2559ea911f4e93fd597 /net-misc/howl/howl-0.8.3.ebuild
parentCommitting the whole ball of wax for Sandy (to close Bug #33943) (diff)
downloadhistorical-6aeb017bf4e93caaeb1233a3d330f96c713236a0.tar.gz
historical-6aeb017bf4e93caaeb1233a3d330f96c713236a0.tar.bz2
historical-6aeb017bf4e93caaeb1233a3d330f96c713236a0.zip
Committing the whole ball of wax for Sandy (to close Bug #33943)
Diffstat (limited to 'net-misc/howl/howl-0.8.3.ebuild')
-rw-r--r--net-misc/howl/howl-0.8.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/howl/howl-0.8.3.ebuild b/net-misc/howl/howl-0.8.3.ebuild
new file mode 100644
index 000000000000..58895008705c
--- /dev/null
+++ b/net-misc/howl/howl-0.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.8.3.ebuild,v 1.1 2003/12/27 16:25:28 lisa Exp $
+
+DESCRIPTION="Howl is a cross-platform implementation of the Zeroconf networking standard. Zeroconf brings a new ease of use to IP networking."
+HOMEPAGE="http://www.porchdogsoft.com/products/howl/"
+SRC_URI="http://www.porchdogsoft.com/download/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+DEPEND="sys-libs/glibc" # sys-devel/automake - needed if we remove the html docs from /usr/share
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # If we wanted to remove the html docs in /usr/share/howl....
+ #einfo "Removing html docs from build process...."
+ #sed -e 's/ docs//' < Makefile.am > Makefile.am.new || die "sed failed"
+ #mv Makefile.am.new Makefile.am || die "move failed"
+ #aclocal || die "aclocal failed"
+ #automake || die "automake failed"
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dohtml -r docs/
+
+ # nifd service loader
+ dodir /etc/conf.d
+ cp ${FILESDIR}/nifd.conf.d ${D}/etc/conf.d/nifd || die "cp ${FILESDIR}/nifd.conf.d ${D}/etc/conf.d/nifd"
+ dodir /etc/init.d
+ cp ${FILESDIR}/nifd.init.d ${D}/etc/init.d/nifd || die "cp ${FILESDIR}/nifd.init.d ${D}/etc/init.d/nifd"
+ fperms a+x ${D}/etc/init.d/nifd
+
+ # mDNSResponder service loader
+ dodir /etc/conf.d
+ cp ${FILESDIR}/mDNSResponder.conf.d ${D}/etc/conf.d/mDNSResponder || die "cp ${FILESDIR}/mDNSResponder.conf.d ${D}/etc/conf.d/mDNSResponder"
+ dodir /etc/init.d
+ cp ${FILESDIR}/mDNSResponder.init.d ${D}/etc/init.d/mDNSResponder || die "cp ${FILESDIR}/mDNSResponder.init.d ${D}/etc/init.d/mDNSResponder"
+ fperms a+x ${D}/etc/init.d/mDNSResponder
+}