summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2002-11-30 05:53:45 +0000
committerJon Nall <nall@gentoo.org>2002-11-30 05:53:45 +0000
commita77baf68a738326f82dad791c8cadd6a11dbb296 (patch)
tree8bcc4e2ca94240fe737e7c44b4ade2413f9089cd /net-misc/logjam/logjam-4.0.0.ebuild
parentChanged econf||die to econf (diff)
downloadhistorical-a77baf68a738326f82dad791c8cadd6a11dbb296.tar.gz
historical-a77baf68a738326f82dad791c8cadd6a11dbb296.tar.bz2
historical-a77baf68a738326f82dad791c8cadd6a11dbb296.zip
updated to newest version (4.0.0)
Diffstat (limited to 'net-misc/logjam/logjam-4.0.0.ebuild')
-rw-r--r--net-misc/logjam/logjam-4.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/logjam/logjam-4.0.0.ebuild b/net-misc/logjam/logjam-4.0.0.ebuild
new file mode 100644
index 000000000000..611089edeecd
--- /dev/null
+++ b/net-misc/logjam/logjam-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.0.0.ebuild,v 1.1 2002/11/30 05:53:45 nall Exp $
+
+IUSE="xmms spell"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK2-based LiveJournal client"
+HOMEPAGE="http://logjam.danga.com/"
+SRC_URI=http://logjam.danga.com/download/${P}.tar.gz
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+
+DEPEND="=x11-libs/gtk+-2*
+ net-ftp/curl
+ spell? ( app-text/gtkspell )
+ xmms? ( media-sound/xmms )"
+
+src_compile () {
+ local myconf
+
+ use xmms && myconf="${myconf} --enable-xmms"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README TODO ChangeLog COPYING AUTHORS
+}