summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-06-06 10:43:15 +0000
committerNaohiro Aota <naota@gentoo.org>2011-06-06 10:43:15 +0000
commit44ead27ed9e5dafe36ee13d2599d6b3f2e7b7143 (patch)
tree0d6508355ec9759b1a6a0816f8817a004dd631c7 /net-misc/mikutter/mikutter-0.0.3.7.ebuild
parentDrop old version (diff)
downloadhistorical-44ead27ed9e5dafe36ee13d2599d6b3f2e7b7143.tar.gz
historical-44ead27ed9e5dafe36ee13d2599d6b3f2e7b7143.tar.bz2
historical-44ead27ed9e5dafe36ee13d2599d6b3f2e7b7143.zip
Version bumped
Package-Manager: portage-2.2.0_alpha37/cvs/Linux x86_64
Diffstat (limited to 'net-misc/mikutter/mikutter-0.0.3.7.ebuild')
-rw-r--r--net-misc/mikutter/mikutter-0.0.3.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/mikutter/mikutter-0.0.3.7.ebuild b/net-misc/mikutter/mikutter-0.0.3.7.ebuild
new file mode 100644
index 000000000000..372e4c1d86bf
--- /dev/null
+++ b/net-misc/mikutter/mikutter-0.0.3.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/mikutter-0.0.3.7.ebuild,v 1.1 2011/06/06 10:43:15 naota Exp $
+
+EAPI=3
+
+USE_RUBY="ruby18 ruby19"
+
+inherit ruby-ng
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="mikutter is simple, powerful and moeful twitter client"
+HOMEPAGE="http://mikutter.hachune.net/"
+SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+libnotify sqlite"
+
+DEPEND=""
+RDEPEND="$(ruby_implementation_depend ruby18 '>=' -1.8.7)[ssl]
+ libnotify? ( x11-libs/libnotify )"
+
+ruby_add_rdepend "dev-ruby/ruby-gtk2
+ dev-ruby/rcairo
+ dev-ruby/ruby-hmac
+ dev-ruby/httpclient"
+
+S="${WORKDIR}/${PN}"
+
+each_ruby_install() {
+ exeinto /usr/share/mikutter
+ doexe mikutter.rb
+ insinto /usr/share/mikutter
+ doins -r core plugin
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/mikutter
+ dodoc README
+}