summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-11-25 18:31:11 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-11-25 18:31:11 +0000
commitcf3399e122f6380b2d616b4d63b77b5b9b6c3e1c (patch)
treed4785c64dce0839318e71bc725d91f4e1eff37e6 /net-misc/mknbi/mknbi-1.4.4.ebuild
parent1.4 version bump for bug 112778 (diff)
downloadhistorical-cf3399e122f6380b2d616b4d63b77b5b9b6c3e1c.tar.gz
historical-cf3399e122f6380b2d616b4d63b77b5b9b6c3e1c.tar.bz2
historical-cf3399e122f6380b2d616b4d63b77b5b9b6c3e1c.zip
1.4.4 version bump for bug 112724
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-misc/mknbi/mknbi-1.4.4.ebuild')
-rw-r--r--net-misc/mknbi/mknbi-1.4.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/mknbi/mknbi-1.4.4.ebuild b/net-misc/mknbi/mknbi-1.4.4.ebuild
new file mode 100644
index 000000000000..cd669d69ca4a
--- /dev/null
+++ b/net-misc/mknbi/mknbi-1.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mknbi/mknbi-1.4.4.ebuild,v 1.1 2005/11/25 18:31:11 vanquirius Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Utility for making tagged kernel images useful for netbooting"
+SRC_URI="mirror://sourceforge/etherboot/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://etherboot.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.1
+ dev-lang/nasm"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/mknbi-1.4.3-nossp.patch
+}
+
+src_compile() {
+ sed -i -e "s:\/usr\/local:\/usr:" Makefile
+
+ #apply modifications to CFLAGS to fix for gcc 3.4: bug #64049
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ sed -i -e "s:\-mcpu:\-mtune:" Makefile
+ sed -i -e "s:CFLAGS=:CFLAGS= -minline-all-stringops:" Makefile
+ fi
+
+ emake || die "Compile failed"
+}
+
+src_install() {
+ export BUILD_ROOT="${D}"
+ make DESTDIR="${D}" install || die "Installation failed"
+}