summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-12-06 19:37:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-12-06 19:37:39 +0000
commit830814153f07a00eada7e81868e02a2e69bea05a (patch)
tree305a77da5cccc5a8f3eabba56e99cc133959a983 /net-misc/nstx/nstx-1.1_beta6-r3.ebuild
parentVersion bump, bug 295998. (diff)
downloadhistorical-830814153f07a00eada7e81868e02a2e69bea05a.tar.gz
historical-830814153f07a00eada7e81868e02a2e69bea05a.tar.bz2
historical-830814153f07a00eada7e81868e02a2e69bea05a.zip
Bug #262765, #260925, #156491: Submission by Steve Brudenell <steven.brudenell@gmail.com> that fixes outstanding bugs and adds init scripts.
Package-Manager: portage-2.2_rc55/cvs/Linux x86_64
Diffstat (limited to 'net-misc/nstx/nstx-1.1_beta6-r3.ebuild')
-rw-r--r--net-misc/nstx/nstx-1.1_beta6-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/nstx/nstx-1.1_beta6-r3.ebuild b/net-misc/nstx/nstx-1.1_beta6-r3.ebuild
new file mode 100644
index 000000000000..baa599e24a16
--- /dev/null
+++ b/net-misc/nstx/nstx-1.1_beta6-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nstx/nstx-1.1_beta6-r3.ebuild,v 1.1 2009/12/06 19:37:39 robbat2 Exp $
+
+inherit versionator toolchain-funcs eutils linux-info
+
+MY_PV=$(replace_version_separator 2 - "${PV}")
+MY_P="${PN}-${MY_PV}"
+DEBIAN_PV="5"
+DEBIAN_A="${PN}_${MY_PV}-${DEBIAN_PV}.diff.gz"
+
+DESCRIPTION="IP over DNS tunnel"
+SRC_URI="http://dereference.de/nstx/${MY_P}.tgz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEBIAN_A}"
+HOMEPAGE="http://dereference.de/nstx/"
+RDEPEND="virtual/libc"
+DEPEND="virtual/os-headers
+ ${RDEPEND}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~TUN"
+
+src_unpack() {
+ unpack "${MY_P}.tgz"
+ epatch "${DISTDIR}"/${DEBIAN_A}
+ epatch "${FILESDIR}"/${PN}-1.1_beta6_00-linux-tuntap.patch
+ epatch "${FILESDIR}"/${PN}-1.1_beta6_01-bind-interface-name.patch
+ epatch "${FILESDIR}"/${PN}-1.1_beta6_02-warn-on-frag.patch
+ epatch "${FILESDIR}"/${PN}-1.1_beta6_03-delete-dwrite.patch
+ epatch "${FILESDIR}"/${PN}-1.1_beta6_04-delete-werror.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ into /usr
+ dosbin nstxcd nstxd
+ dodoc README Changelog
+ doman *.8
+
+ newinitd "${FILESDIR}"/nstxd.init nstxd
+ newconfd "${FILESDIR}"/nstxd.conf nstxd
+ newinitd "${FILESDIR}"/nstxcd.init nstxcd
+ newconfd "${FILESDIR}"/nstxcd.conf nstxcd
+}
+
+pkg_postinst() {
+ einfo "Please read the documentation provided in"
+ einfo " `find /usr/share/doc/${PF}/ -name 'README*'`"
+}