summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-10-10 06:30:43 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-10-10 06:30:43 +0000
commit602993e824f8e7bc7bf90c1111c8c26544c56e05 (patch)
tree583367a13003717f1b09d839c7dd82d020b4e0ea /net-misc/quagga/files
parentdev-lang/idb: Bump to correct version, thanks Arfrever for pinging me (diff)
downloadhistorical-602993e824f8e7bc7bf90c1111c8c26544c56e05.tar.gz
historical-602993e824f8e7bc7bf90c1111c8c26544c56e05.tar.bz2
historical-602993e824f8e7bc7bf90c1111c8c26544c56e05.zip
Security cleanup wrt bug #475706
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x1F357D42
Diffstat (limited to 'net-misc/quagga/files')
-rw-r--r--net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch136
-rw-r--r--net-misc/quagga/files/quagga-link-libcap.patch24
-rw-r--r--net-misc/quagga/files/quagga-services.init.253
-rw-r--r--net-misc/quagga/files/zebra.init.355
4 files changed, 0 insertions, 268 deletions
diff --git a/net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch b/net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch
deleted file mode 100644
index ad476652058b..000000000000
--- a/net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch
+++ /dev/null
@@ -1,136 +0,0 @@
-Fix building with no IPv6 support
-https://dev.openwrt.org/changeset/32697
-
-Index: quagga-0.99.21/zebra/main.c
-===================================================================
---- quagga-0.99.21.orig/zebra/main.c
-+++ quagga-0.99.21/zebra/main.c
-@@ -327,7 +327,9 @@ main (int argc, char **argv)
- zebra_vty_init ();
- access_list_init ();
- prefix_list_init ();
-+#ifdef RTADV
- rtadv_init ();
-+#endif
- #ifdef HAVE_IRDP
- irdp_init();
- #endif
-Index: quagga-0.99.21/zebra/rtadv.h
-===================================================================
---- quagga-0.99.21.orig/zebra/rtadv.h
-+++ quagga-0.99.21/zebra/rtadv.h
-@@ -26,6 +26,9 @@
- #include "vty.h"
- #include "zebra/interface.h"
-
-+/* NB: RTADV is defined in zebra/interface.h above */
-+#ifdef RTADV
-+
- /* Router advertisement prefix. */
- struct rtadv_prefix
- {
-@@ -96,4 +99,6 @@ struct nd_opt_homeagent_info { /* Home
-
- extern const char *rtadv_pref_strs[];
-
-+#endif /* RTADV */
-+
- #endif /* _ZEBRA_RTADV_H */
-Index: quagga-0.99.21/zebra/zebra_vty.c
-===================================================================
---- quagga-0.99.21.orig/zebra/zebra_vty.c
-+++ quagga-0.99.21/zebra/zebra_vty.c
-@@ -1197,6 +1197,40 @@ DEFUN (show_ip_protocol,
- return CMD_SUCCESS;
- }
-
-+/*
-+ * Show IP mroute command to dump the BGP Multicast
-+ * routing table
-+ */
-+DEFUN (show_ip_mroute,
-+ show_ip_mroute_cmd,
-+ "show ip mroute",
-+ SHOW_STR
-+ IP_STR
-+ "IP Multicast routing table\n")
-+{
-+ struct route_table *table;
-+ struct route_node *rn;
-+ struct rib *rib;
-+ int first = 1;
-+
-+ table = vrf_table (AFI_IP, SAFI_MULTICAST, 0);
-+ if (! table)
-+ return CMD_SUCCESS;
-+
-+ /* Show all IPv4 routes. */
-+ for (rn = route_top (table); rn; rn = route_next (rn))
-+ for (rib = rn->info; rib; rib = rib->next)
-+ {
-+ if (first)
-+ {
-+ vty_out (vty, SHOW_ROUTE_V4_HEADER);
-+ first = 0;
-+ }
-+ vty_show_ip_route (vty, rn, rib);
-+ }
-+ return CMD_SUCCESS;
-+}
-+
-
- #ifdef HAVE_IPV6
- /* General fucntion for IPv6 static route. */
-@@ -1952,40 +1986,6 @@ DEFUN (show_ipv6_route_summary,
- }
-
- /*
-- * Show IP mroute command to dump the BGP Multicast
-- * routing table
-- */
--DEFUN (show_ip_mroute,
-- show_ip_mroute_cmd,
-- "show ip mroute",
-- SHOW_STR
-- IP_STR
-- "IP Multicast routing table\n")
--{
-- struct route_table *table;
-- struct route_node *rn;
-- struct rib *rib;
-- int first = 1;
--
-- table = vrf_table (AFI_IP, SAFI_MULTICAST, 0);
-- if (! table)
-- return CMD_SUCCESS;
--
-- /* Show all IPv4 routes. */
-- for (rn = route_top (table); rn; rn = route_next (rn))
-- for (rib = rn->info; rib; rib = rib->next)
-- {
-- if (first)
-- {
-- vty_out (vty, SHOW_ROUTE_V4_HEADER);
-- first = 0;
-- }
-- vty_show_ip_route (vty, rn, rib);
-- }
-- return CMD_SUCCESS;
--}
--
--/*
- * Show IPv6 mroute command.Used to dump
- * the Multicast routing table.
- */
-@@ -2020,11 +2020,6 @@ DEFUN (show_ipv6_mroute,
- return CMD_SUCCESS;
- }
-
--
--
--
--
--
- /* Write IPv6 static route configuration. */
- static int
- static_config_ipv6 (struct vty *vty)
diff --git a/net-misc/quagga/files/quagga-link-libcap.patch b/net-misc/quagga/files/quagga-link-libcap.patch
deleted file mode 100644
index 7e63c7f2eb79..000000000000
--- a/net-misc/quagga/files/quagga-link-libcap.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Nru quagga-0.99.8.orig/lib/Makefile.am quagga-0.99.8/lib/Makefile.am
---- quagga-0.99.8.orig/lib/Makefile.am 2006-06-27 10:48:16.000000000 +0300
-+++ quagga-0.99.8/lib/Makefile.am 2007-08-13 22:09:10.000000000 +0300
-@@ -18,7 +18,7 @@
-
- libzebra_la_DEPENDENCIES = @LIB_REGEX@
-
--libzebra_la_LIBADD = @LIB_REGEX@
-+libzebra_la_LIBADD = @LIB_REGEX@ @LIBCAP@
-
- pkginclude_HEADERS = \
- buffer.h checksum.h command.h filter.h getopt.h hash.h \
-diff -Nru quagga-0.99.8.orig/zebra/Makefile.am quagga-0.99.8/zebra/Makefile.am
---- quagga-0.99.8.orig/zebra/Makefile.am 2007-05-02 18:28:33.000000000 +0300
-+++ quagga-0.99.8/zebra/Makefile.am 2007-08-13 22:09:10.000000000 +0300
-@@ -36,7 +36,7 @@
- connected.h ioctl.h rib.h rt.h zserv.h redistribute.h debug.h rtadv.h \
- interface.h ipforward.h irdp.h router-id.h kernel_socket.h
-
--zebra_LDADD = $(otherobj) $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la
-+zebra_LDADD = $(otherobj) ../lib/libzebra.la $(LIBCAP) $(LIB_IPV6)
-
- testzebra_LDADD = $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la
-
diff --git a/net-misc/quagga/files/quagga-services.init.2 b/net-misc/quagga/files/quagga-services.init.2
deleted file mode 100644
index c05face00458..000000000000
--- a/net-misc/quagga/files/quagga-services.init.2
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/files/quagga-services.init.2,v 1.3 2011/09/27 21:51:34 flameeyes Exp $
-
-: ${CFGFILE:=/etc/quagga/${SVCNAME}.conf}
-
-get_service_config() {
- [ -e "$CFGFILE" ] || return
-
- awk '$1 == "'$1'" { s=$2 } END { print s }' "$CFGFILE"
-}
-
-depend() {
- config "$CFGFILE"
-
- need zebra
-
- [ "$(get_service_config log)" = "syslog" ] && \
- use logger
-}
-
-start() {
- if [ ! -e "${CFGFILE}" ] ; then
- eerror "Before starting ${SVCNAME} you have to configure it, by creating"
- eerror "a ${CFGFILE} file."
- eerror ""
- eerror "A sample file has been installed in `ls /usr/share/doc/quagga-*/samples/${SVCNAME}.conf.sample`"
- return 1
- fi
-
- if [ ! -d /var/run/quagga ] ; then
- mkdir -p /var/run/quagga
- chown quagga:quagga /var/run/quagga
- chmod 0750 /var/run/quagga
- fi
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon \
- --start --exec /usr/sbin/${SVCNAME} \
- --pidfile /var/run/quagga/${SVCNAME}.pid \
- -- -d -f "${CFGFILE}" ${EXTRA_OPTS} \
- --pid_file /var/run/quagga/${SVCNAME}.pid
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop \
- --pidfile /var/run/quagga/${SVCNAME}.pid
- eend $?
-}
diff --git a/net-misc/quagga/files/zebra.init.3 b/net-misc/quagga/files/zebra.init.3
deleted file mode 100644
index b0c6f92f3c40..000000000000
--- a/net-misc/quagga/files/zebra.init.3
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/files/zebra.init.3,v 1.2 2011/09/27 21:50:12 flameeyes Exp $
-
-: ${CFGFILE:=/etc/quagga/${SVCNAME}.conf}
-
-get_service_config() {
- awk '$1 == "'$1'" { s=$2 } END { print s }' "$CFGFILE"
-}
-
-depend() {
- config "$CFGFILE"
-
- need net
-
- [ "$(get_service_config log)" = "syslog" ] && \
- use logger
-}
-
-start() {
- if [ ! -e "${CFGFILE}" ] ; then
- eerror "Before starting ${SVCNAME} you have to configure it, by creating"
- eerror "a ${CFGFILE} file."
- eerror ""
- eerror "A sample file has been installed in `ls /usr/share/doc/quagga-*/samples/${SVCNAME}.conf.sample`"
- return 1
- fi
-
- if [ ! -d /var/run/quagga ] ; then
- mkdir -p /var/run/quagga
- chown quagga:quagga /var/run/quagga
- chmod 0750 /var/run/quagga
- fi
-
- ebegin "Cleaning up stale zebra routes..."
- ip route flush proto zebra
- eend $?
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon \
- --start --exec /usr/sbin/${SVCNAME} \
- --pidfile /var/run/quagga/${SVCNAME}.pid \
- -- -d -f "${CFGFILE}" ${EXTRA_OPTS} \
- --pid_file /var/run/quagga/${SVCNAME}.pid
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop \
- --pidfile /var/run/quagga/${SVCNAME}.pid
- eend $?
-}