summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-03-10 14:36:58 +0000
committerAron Griffis <agriffis@gentoo.org>2004-03-10 14:36:58 +0000
commitfac0c5524a5fdd653ad4c7a94d35d07804cddff0 (patch)
tree62909f53b5d1b0c8b1ef3bbafe874b466b5a95af /net-misc/rdist/rdist-6.1.5-r1.ebuild
parentFixing to properly use games.eclass and closing bug #44220. (diff)
downloadhistorical-fac0c5524a5fdd653ad4c7a94d35d07804cddff0.tar.gz
historical-fac0c5524a5fdd653ad4c7a94d35d07804cddff0.tar.bz2
historical-fac0c5524a5fdd653ad4c7a94d35d07804cddff0.zip
Fix bug 41781 by using yacc and ARG_TYPE=ARG_STDARG. Thanks to Antti Hätälä and Horst Prote for the fix.
Diffstat (limited to 'net-misc/rdist/rdist-6.1.5-r1.ebuild')
-rw-r--r--net-misc/rdist/rdist-6.1.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/rdist/rdist-6.1.5-r1.ebuild b/net-misc/rdist/rdist-6.1.5-r1.ebuild
new file mode 100644
index 000000000000..43abc48dd201
--- /dev/null
+++ b/net-misc/rdist/rdist-6.1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdist/rdist-6.1.5-r1.ebuild,v 1.1 2004/03/10 14:36:58 agriffis Exp $
+
+DESCRIPTION="Remote software distribution system"
+HOMEPAGE="http://www.magnicomp.com/rdist/rdist.shtml"
+SRC_URI="http://www.magnicomp.com/download/rdist/${P}.tar.gz"
+
+LICENSE="RDist"
+SLOT="1"
+KEYWORDS="x86 sparc alpha ia64"
+
+DEPEND="dev-util/yacc >=sys-apps/sed-4"
+RDEPEND="" # yacc only needed for compile
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die
+
+ # Fix for bug 41781: Build with yacc instead of bison and change
+ # the following #define (10 Mar 2004 agriffis)
+ sed -i -e 's/^\(#define ARG_TYPE\).*/\1 ARG_STDARG/' config/os-linux.h
+ assert "sed ARG_TYPE failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man{1,8}
+ make install BIN_DIR=${D}/usr/bin || die "make install failed"
+ make install.man \
+ MAN_1_DIR=${D}/usr/share/man/man1 MAN_8_DIR=${D}/usr/share/man/man8 \
+ || die "make install.man failed"
+}