summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 21:14:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 21:14:31 +0000
commit6bd2399e52181c8715b9d3a23962cfec706e0aa3 (patch)
treea3b5ed610ca2ee536e041ca5414a188716edd687 /net-misc/vnc
parentremoved older ebuild (diff)
downloadhistorical-6bd2399e52181c8715b9d3a23962cfec706e0aa3.tar.gz
historical-6bd2399e52181c8715b9d3a23962cfec706e0aa3.tar.bz2
historical-6bd2399e52181c8715b9d3a23962cfec706e0aa3.zip
cleanup
Diffstat (limited to 'net-misc/vnc')
-rw-r--r--net-misc/vnc/vnc-3.3.3-r2.ebuild48
1 files changed, 23 insertions, 25 deletions
diff --git a/net-misc/vnc/vnc-3.3.3-r2.ebuild b/net-misc/vnc/vnc-3.3.3-r2.ebuild
index e916d030587a..010d6761e644 100644
--- a/net-misc/vnc/vnc-3.3.3-r2.ebuild
+++ b/net-misc/vnc/vnc-3.3.3-r2.ebuild
@@ -2,49 +2,47 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Grant Goodyear <g2boojum@hotmail.com>
# /home/cvsroot/gentoo-x86/skel.build,v 1.2 2001/02/15 18:17:31 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r2.ebuild,v 1.6 2002/04/11 17:07:47 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r2.ebuild,v 1.7 2002/04/27 21:13:04 seemant Exp $
-#P=
-A="vnc-3.3.3r2_unixsrc.tgz"
+MY_P="vnc-3.3.3r2_unixsrc"
S=${WORKDIR}/vnc_unixsrc
DESCRIPTION=""
-SRC_URI="http://www.uk.research.att.com/vnc/dist/${A}"
+SRC_URI="http://www.uk.research.att.com/vnc/dist/${MY_P}.tgz"
HOMEPAGE="http://www.uk.research.att.com/vnc/index.html"
DEPEND="virtual/x11"
src_compile() {
- #imake and the vnc build process possess amazing suckage skills
- #hoping some poor developer takes pitty on vnc and fixes it
+ #imake and the vnc build process possess amazing suckage skills
+ #hoping some poor developer takes pitty on vnc and fixes it
- cd ${S}
- cd Xvnc/config/cf
- mv Imake.cf Imake.cf.orig
- #insist that the machine is an i386 for the Xvnc build
- sed -e '/#ifdef linux/a\# define i386' Imake.cf.orig > Imake.cf
- cd ${S}
- xmkmf || die
+ cd ${S}
+ cd Xvnc/config/cf
+ mv Imake.cf Imake.cf.orig
+ #insist that the machine is an i386 for the Xvnc build
+ sed -e '/#ifdef linux/a\# define i386' Imake.cf.orig > Imake.cf
+ cd ${S}
+ xmkmf || die
- #FIXME: my dirty little fix to fix imake brain damage
- make Makefiles || die
- make depend || die
- cp ${FILESDIR}/vncviewer-makefile-3.3.3r2 ${S}/vncviewer/Makefile
+ #FIXME: my dirty little fix to fix imake brain damage
+ make Makefiles || die
+ make depend || die
+ cp ${FILESDIR}/vncviewer-makefile-3.3.3r2 ${S}/vncviewer/Makefile
- make all || die
+ make all || die
- #FIXME: Xvnc build doesn't respect user CFLAGS settings
- cd Xvnc
- make World || die
+ #FIXME: Xvnc build doesn't respect user CFLAGS settings
+ cd Xvnc
+ make World || die
}
src_install () {
- cd ${S}
- mkdir -p ${D}/usr/bin
- ./vncinstall ${D}/usr/bin || die
+ cd ${S}
+ mkdir -p ${D}/usr/bin
+ ./vncinstall ${D}/usr/bin || die
}
-