summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-06-25 21:57:34 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-06-25 21:57:34 +0000
commit5f68a5a6b36bc42f42cac4070539dd18e56b1741 (patch)
treebe41f9481bb87ea53ad3aeef06cd0115d6e4f867 /net-misc/whois
parentVersion bumped. (diff)
downloadhistorical-5f68a5a6b36bc42f42cac4070539dd18e56b1741.tar.gz
historical-5f68a5a6b36bc42f42cac4070539dd18e56b1741.tar.bz2
historical-5f68a5a6b36bc42f42cac4070539dd18e56b1741.zip
Version bumped.
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/Manifest4
-rw-r--r--net-misc/whois/files/digest-whois-4.6.61
-rw-r--r--net-misc/whois/whois-4.6.6.ebuild49
3 files changed, 52 insertions, 2 deletions
diff --git a/net-misc/whois/Manifest b/net-misc/whois/Manifest
index 3f20b3a44776..9e8f973ceb69 100644
--- a/net-misc/whois/Manifest
+++ b/net-misc/whois/Manifest
@@ -1,8 +1,8 @@
-MD5 ae9d9b0c9e0a844d3d2fe6a47071d401 ChangeLog 3008
+MD5 9ae434a6838b5319edb766108fd20cc3 ChangeLog 3126
MD5 9fec9226a0f38d1f96541d99aaa36b6b whois-4.5.28-r1.ebuild 1230
MD5 6c69bac534e9026d4a96a72a23f4a353 whois-4.6.2.ebuild 1246
MD5 ff618520f6c5885e537b2b53ab552bae whois-4.6.5.ebuild 1121
-MD5 ff618520f6c5885e537b2b53ab552bae whois-4.6.6.ebuild 1121
+MD5 93b4b3e5927a53bbabb9c4a075ca6f00 whois-4.6.6.ebuild 1125
MD5 e5bfe59600d5004e660bc25b44ef57cb files/digest-whois-4.5.28-r1 63
MD5 e0ddfa19a7be8e839b1230c90cf7f212 files/digest-whois-4.6.2 62
MD5 32a907197a525d414f902c78fee2be6e files/digest-whois-4.6.5 62
diff --git a/net-misc/whois/files/digest-whois-4.6.6 b/net-misc/whois/files/digest-whois-4.6.6
new file mode 100644
index 000000000000..36ed1f444de6
--- /dev/null
+++ b/net-misc/whois/files/digest-whois-4.6.6
@@ -0,0 +1 @@
+MD5 eceebd6e1aaa82b376eee30f59032662 whois_4.6.6.tar.gz 46077
diff --git a/net-misc/whois/whois-4.6.6.ebuild b/net-misc/whois/whois-4.6.6.ebuild
new file mode 100644
index 000000000000..003a67e79d1a
--- /dev/null
+++ b/net-misc/whois/whois-4.6.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.6.6.ebuild,v 1.1 2003/06/25 21:55:28 mholzer Exp $
+
+IUSE="nls"
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+SRC_URI="http://www.linux.it/~md/software/${MY_P}.tar.gz"
+HOMEPAGE="http://www.linux.it/~md/software/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~hppa ~arm"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-lang/perl-5"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s/-O2/$CFLAGS/" Makefile
+
+ use nls && ( \
+ cd po
+ sed -i "s:/usr/bin/install:/bin/install:" Makefile
+ ) || ( \
+ sed -i "s:cd po.*::" Makefile
+ )
+}
+
+src_compile() {
+ make || die
+ make mkpasswd || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ use nls && dodir /usr/share/locale
+ make BASEDIR=${D} prefix=/usr mandir=/usr/share/man install || die
+
+ dobin mkpasswd
+ doman mkpasswd.1
+ dodoc README whois.conf debian/changelog debian/copyright
+
+ einfo ""
+ einfo "The example whois.conf is located in /usr/doc/${P}"
+ einfo ""
+}