summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-05 08:35:24 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-05 08:35:24 +0000
commitd83f443cd72e8461afc682dca53329aad823d172 (patch)
treeb547b744d139ff24b866852a0bbacd4457803901 /net-misc/whois
parentVersion bump. (diff)
downloadhistorical-d83f443cd72e8461afc682dca53329aad823d172.tar.gz
historical-d83f443cd72e8461afc682dca53329aad823d172.tar.bz2
historical-d83f443cd72e8461afc682dca53329aad823d172.zip
old
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/files/whois-4.7.26-gentoo-security.patch79
-rw-r--r--net-misc/whois/whois-5.0.6.ebuild50
-rw-r--r--net-misc/whois/whois-5.0.7.ebuild50
3 files changed, 0 insertions, 179 deletions
diff --git a/net-misc/whois/files/whois-4.7.26-gentoo-security.patch b/net-misc/whois/files/whois-4.7.26-gentoo-security.patch
deleted file mode 100644
index 9757604bde13..000000000000
--- a/net-misc/whois/files/whois-4.7.26-gentoo-security.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- whois-4.7.26/whois.c
-+++ whois-4.7.26/whois.c
-@@ -87,7 +87,7 @@
- /* RIPE flags */
- if (strchr(ripeflags, ch)) {
- for (p = fstring; *p; p++);
-- sprintf(p--, "-%c ", ch);
-+ snprintf(p--, sizeof(fstring), "-%c ", ch);
- continue;
- }
- if (strchr(ripeflagsp, ch)) {
-@@ -141,10 +141,10 @@
- while (1) {
- qslen += strlen(*argv) + 1 + 1;
- qstring = realloc(qstring, qslen);
-- strcat(qstring, *argv++);
-+ strncat(qstring, *argv++, qslen-1);
- if (argc == 1)
- break;
-- strcat(qstring, " ");
-+ strncat(qstring, " ", qslen-1);
- argc--;
- }
- }
-@@ -467,8 +467,10 @@
- char *buf, *p;
- int i, isripe = 0;
-
-+ /* buflen was always 0 in original patch and buf was allocated twice /Aye */
- /* 64 bytes reserved for server-specific flags added later */
-- buf = malloc(strlen(flags) + strlen(query) + strlen(client_tag) + 64);
-+ int buflen = strlen(flags) + strlen(query) + strlen(client_tag) + 64;
-+ buf = malloc(buflen);
- *buf = '\0';
- for (i = 0; ripe_servers[i]; i++)
- if (streq(server, ripe_servers[i])) {
-@@ -481,7 +483,7 @@
- if (*flags) {
- if (!isripe && !streq(server, "whois.corenic.net"))
- puts(_("Warning: RIPE flags used with a traditional server."));
-- strcat(buf, flags);
-+ strncat(buf, flags, buflen-1);
- }
-
- #ifdef HAVE_LIBIDN
-@@ -490,28 +492,28 @@
- */
- if (streq(server, "whois.denic.de") && domcmp(query, ".de")
- && !strchr(query, ' ') && !*flags)
-- sprintf(buf, "-T dn,ace -C US-ASCII %s", query);
-+ snprintf(buf, buflen-1, "-T dn,ace -C US-ASCII %s", query);
- else
- /* here we have another registrar who could not make things simple
- * -C sets the language for both input and output
- */
- if (!isripe && streq(server, "whois.cat") && domcmp(query, ".cat")
- && !strchr(query, ' '))
-- sprintf(buf, "-C US-ASCII ace %s", query);
-+ snprintf(buf, buflen-1, "-C US-ASCII ace %s", query);
- else
- #endif
- if (!isripe && (streq(server, "whois.nic.mil") ||
- streq(server, "whois.nic.ad.jp")) &&
- strncaseeq(query, "AS", 2) && isasciidigit(query[2]))
- /* FIXME: /e is not applied to .JP ASN */
-- sprintf(buf, "AS %s", query + 2); /* fix query for DDN */
-+ snprintf(buf, buflen-1, "AS %s", query + 2); /* fix query for DDN */
- else if (!isripe && (streq(server, "whois.nic.ad.jp") ||
- streq(server, "whois.jprs.jp"))) {
- char *lang = getenv("LANG"); /* not a perfect check, but... */
- if (!lang || !strneq(lang, "ja", 2))
-- sprintf(buf, "%s/e", query); /* ask for english text */
-+ snprintf(buf, buflen-1, "%s/e", query); /* ask for english text */
- else
-- strcat(buf, query);
-+ strncat(buf, query, buflen-1);
- } else if (!isripe && streq(server, "whois.arin.net") &&
- (p = strrchr(query, '/'))) {
- strncat(buf, query, p - query); /* strip CIDR */
diff --git a/net-misc/whois/whois-5.0.6.ebuild b/net-misc/whois/whois-5.0.6.ebuild
deleted file mode 100644
index cd044a234a83..000000000000
--- a/net-misc/whois/whois-5.0.6.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.6.ebuild,v 1.2 2010/07/28 15:32:33 darkside Exp $
-
-EAPI=3
-inherit eutils toolchain-funcs
-
-MY_P=${P/-/_}
-DESCRIPTION="improved Whois Client"
-HOMEPAGE="http://www.linux.it/~md/software/"
-SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="nls"
-RESTRICT="test" #59327
-
-RDEPEND="net-dns/libidn"
-DEPEND="${RDEPEND}
- >=dev-lang/perl-5"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
-
- if use nls ; then
- sed -i -e 's:#\(.*pos\):\1:' Makefile
- else
- sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
- fi
-}
-
-src_configure() { :;} # expected no-op
-
-src_compile() {
- tc-export CC
- emake CFLAGS="${CFLAGS} ${CPPFLAGS}" HAVE_LIBIDN=1 || die
-}
-
-src_install() {
- emake BASEDIR="${ED}" prefix=/usr install || die
- insinto /etc
- doins whois.conf
- dodoc README debian/changelog
-
- if [[ ${USERLAND} != "GNU" ]]; then
- mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1
- mv "${ED}"/usr/bin/{whois,mdwhois}
- fi
-}
diff --git a/net-misc/whois/whois-5.0.7.ebuild b/net-misc/whois/whois-5.0.7.ebuild
deleted file mode 100644
index 1ede53ab7969..000000000000
--- a/net-misc/whois/whois-5.0.7.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.7.ebuild,v 1.1 2010/09/25 06:05:06 vapier Exp $
-
-EAPI=3
-inherit eutils toolchain-funcs
-
-MY_P=${P/-/_}
-DESCRIPTION="improved Whois Client"
-HOMEPAGE="http://www.linux.it/~md/software/"
-SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="nls"
-RESTRICT="test" #59327
-
-RDEPEND="net-dns/libidn"
-DEPEND="${RDEPEND}
- >=dev-lang/perl-5"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
-
- if use nls ; then
- sed -i -e 's:#\(.*pos\):\1:' Makefile
- else
- sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
- fi
-}
-
-src_configure() { :;} # expected no-op
-
-src_compile() {
- tc-export CC
- emake CFLAGS="${CFLAGS} ${CPPFLAGS}" HAVE_LIBIDN=1 || die
-}
-
-src_install() {
- emake BASEDIR="${ED}" prefix=/usr install || die
- insinto /etc
- doins whois.conf
- dodoc README debian/changelog
-
- if [[ ${USERLAND} != "GNU" ]]; then
- mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1
- mv "${ED}"/usr/bin/{whois,mdwhois}
- fi
-}