summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-15 10:53:53 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-15 10:53:53 +0000
commit37323617899a0cca86f8ecf2743cc59b922b9211 (patch)
treee076bf88f43b6ed689e929d9faf10ee0dfd44a17 /net-misc
parentAdded tftp (diff)
downloadhistorical-37323617899a0cca86f8ecf2743cc59b922b9211.tar.gz
historical-37323617899a0cca86f8ecf2743cc59b922b9211.tar.bz2
historical-37323617899a0cca86f8ecf2743cc59b922b9211.zip
Update. Changed /var/state/dhcp to /var/lib/dhcp to be FHS2.1 conform
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcp/dhcp-3.0_beta0224.ebuild73
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_beta02241
2 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/dhcp/dhcp-3.0_beta0224.ebuild b/net-misc/dhcp/dhcp-3.0_beta0224.ebuild
new file mode 100644
index 000000000000..f7f177b0a2e2
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0_beta0224.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_beta0224.ebuild,v 1.1 2001/04/15 10:53:53 achim Exp $
+
+P=dhcp-3.0b2pl24
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ echo "CC = gcc ${CFLAGS}" > site.conf
+ echo "ETC = /etc/dhcp" >> site.conf
+ echo "VARDB = /var/lib/dhcp" >> site.conf
+ try ./configure
+ try make
+}
+
+src_install () {
+
+ cd ${S}/work.linux-2.2/client
+ into /usr
+ dosbin dhclient
+ doman *.5 *.8
+
+ cd ../common
+ doman *.5
+
+ cd ../dhcpctl
+ dolib libdhcpctl.a
+ insinto /usr/include
+ doins dhcpctl.h
+
+ cd ../omapip
+ dolib libomapi.a
+ doman *.3
+
+ cd ../relay
+ dosbin dhcrelay
+ doman *.8
+
+ cd ../server
+ dosbin dhcpd
+ doman *.5 *.8
+
+ cd ${S}/client
+ insinto /etc/dhcp
+ doins dhclient.conf
+ donewins scripts/linux dhclient-script
+
+ cd ${S}/server
+ doins dhcpd.conf
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip
+ doins alloc.h buffer.h omapip.h
+ cd ${S}/includes/isc
+ insinto /usr/include/isc
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+ dodir /var/lib/dhcp
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ docinto doc
+ dodoc doc/*
+}
+
+
+
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_beta0224 b/net-misc/dhcp/files/digest-dhcp-3.0_beta0224
new file mode 100644
index 000000000000..0933c3a6c4b2
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0_beta0224
@@ -0,0 +1 @@
+MD5 ea48b791cb2be15c6d3458f5f55de8ca dhcp-3.0b2pl24.tar.gz