summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2 (patch)
treee60f463f55aa5aac16ff1a139d0cbf4a2e4d9128 /net-misc
parent- bah. forgot digest. (diff)
downloadhistorical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.gz
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.bz2
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.zip
*** empty log message ***
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/files/digest-wget-1.71
-rw-r--r--net-misc/wget/wget-1.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/wget/files/digest-wget-1.7 b/net-misc/wget/files/digest-wget-1.7
new file mode 100644
index 000000000000..bd9c04841f43
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.7
@@ -0,0 +1 @@
+MD5 c911a6b937c0a18757d3211fb62831de wget-1.7.tar.gz
diff --git a/net-misc/wget/wget-1.7.ebuild b/net-misc/wget/wget-1.7.ebuild
new file mode 100644
index 000000000000..4ef395b98529
--- /dev/null
+++ b/net-misc/wget/wget-1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7.ebuild,v 1.1 2001/06/05 19:43:20 achim Exp $
+
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from the WWW"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
+ ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ "
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+# if [ "`use ssl`" ] ; then
+# myconf="$myconf --with-ssl=/usr"
+# fi
+ if [ -z "$DEBUG" ] ; then
+ myconf="$myconf --disable-debug"
+ fi
+ try ./configure --prefix=/usr --sysconfdir=/etc/wget --infodir=/usr/share/info $myconf
+ if [ "`use static`" ] ; then
+ try make -e LDFLAGS=\"--static\"
+ else
+ try make
+ fi
+}
+
+src_install() {
+
+ if [ "`use build`" ] ; then
+ dobin src/wget
+ else
+ try make prefix=${D}/usr sysconfdir=${D}/etc/wget infodir=${D}/usr/share/info install
+
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+ fi
+}
+
+