summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-06-16 19:38:05 +0000
committerDonny Davies <woodchip@gentoo.org>2003-06-16 19:38:05 +0000
commit820d5c154c629df75623fa2f7436ef7275776001 (patch)
treebaaf87ffffbdabf62f40fe82bf7e4ce0d71ef2d2 /net-nds/gq/gq-0.7.0_beta2.ebuild
parentbump. (diff)
downloadhistorical-820d5c154c629df75623fa2f7436ef7275776001.tar.gz
historical-820d5c154c629df75623fa2f7436ef7275776001.tar.bz2
historical-820d5c154c629df75623fa2f7436ef7275776001.zip
bump.
Diffstat (limited to 'net-nds/gq/gq-0.7.0_beta2.ebuild')
-rw-r--r--net-nds/gq/gq-0.7.0_beta2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-nds/gq/gq-0.7.0_beta2.ebuild b/net-nds/gq/gq-0.7.0_beta2.ebuild
new file mode 100644
index 000000000000..9c4968b1b045
--- /dev/null
+++ b/net-nds/gq/gq-0.7.0_beta2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gq/gq-0.7.0_beta2.ebuild,v 1.1 2003/06/16 19:37:58 woodchip Exp $
+
+S=${WORKDIR}/${PN}-${PV/_/}
+DESCRIPTION="GTK-based LDAP client"
+
+SRC_URI="mirror://sourceforge/gqclient/${PN}-${PV/_/}.tar.gz"
+HOMEPAGE="http://www.biot.com/gq/"
+IUSE="kerberos jpeg nls ssl"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=net-nds/openldap-2
+ kerberos? ( app-crypt/mit-krb5 )
+ jpeg? ( media-libs/gdk-pixbuf )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local myconf="--enable-browser-dnd --enable-cache"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ use kerberos && myconf="${myconf} --with-kerberos-prefix=/usr"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING NEWS README* TODO
+}