summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-28 16:58:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-28 16:58:15 +0000
commit7b479ad809895cdd2598203156a88590646c28dc (patch)
treed226acc2efb1ce07dfd85ff1d250df080dd3dc81 /net-nds
parentFixed prefix and DEP (diff)
downloadhistorical-7b479ad809895cdd2598203156a88590646c28dc.tar.gz
historical-7b479ad809895cdd2598203156a88590646c28dc.tar.bz2
historical-7b479ad809895cdd2598203156a88590646c28dc.zip
Fixed ldbm issue and FHS2.1 things
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/digest-openldap-1.2.11-r21
-rw-r--r--net-nds/openldap/openldap-1.2.11-r2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-1.2.11-r2 b/net-nds/openldap/files/digest-openldap-1.2.11-r2
new file mode 100644
index 000000000000..2a427cded549
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-1.2.11-r2
@@ -0,0 +1 @@
+MD5 ac469c0fe66ece3893e96182f14b7886 openldap-stable-20000704.tgz
diff --git a/net-nds/openldap/openldap-1.2.11-r2.ebuild b/net-nds/openldap/openldap-1.2.11-r2.ebuild
new file mode 100644
index 000000000000..b6df7bc9cd5d
--- /dev/null
+++ b/net-nds/openldap/openldap-1.2.11-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r2.ebuild,v 1.1 2001/04/28 16:58:15 achim Exp $
+
+A=${PN}-stable-20000704.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-stable/"${A}
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ >=sys-apps/tcp-wrappers-7.6
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/gdbm-1.8.0"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
+ --enable-shell --enable-shared --enable-static \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
+ --with-ldbm-api=gdbm \
+ --mandir=/usr/share/man --libexecdir=/usr/lib
+ try make depend
+ try make
+ cd tests
+ try make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man libexecdir=${D}/usr/lib install
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
+}
+
+
+
+
+