summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-12-17 16:37:48 +0000
committerJeroen Roovers <jer@gentoo.org>2010-12-17 16:37:48 +0000
commit4ee0e5339b53d53955cd8f921ba3720c1f63b2dc (patch)
tree70e164675deb87e9541829617bf3f51f8975a435 /net-nntp/pan/pan-0.133-r1.ebuild
parentDrop maintainership (diff)
downloadhistorical-4ee0e5339b53d53955cd8f921ba3720c1f63b2dc.tar.gz
historical-4ee0e5339b53d53955cd8f921ba3720c1f63b2dc.tar.bz2
historical-4ee0e5339b53d53955cd8f921ba3720c1f63b2dc.zip
Patch for dev-libs/gmime:2.4 (bug #311503).
Package-Manager: portage-2.2.0_alpha8/cvs/Linux i686
Diffstat (limited to 'net-nntp/pan/pan-0.133-r1.ebuild')
-rw-r--r--net-nntp/pan/pan-0.133-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-nntp/pan/pan-0.133-r1.ebuild b/net-nntp/pan/pan-0.133-r1.ebuild
new file mode 100644
index 000000000000..6630ae75ff8c
--- /dev/null
+++ b/net-nntp/pan/pan-0.133-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.133-r1.ebuild,v 1.1 2010/12/17 16:37:48 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="
+ http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2
+ http://dev.gentoo.org/~jer/${P}-gmime-2.4.patch
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="spell"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libpcre-5.0
+ dev-libs/gmime:2.4
+ spell? ( >=app-text/gtkspell-2.0.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch "${DISTDIR}"/${P}-gmime-2.4.patch
+}
+
+src_configure() {
+ econf $(use_with spell gtkspell)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}