summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-10-18 23:02:46 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-10-18 23:02:46 +0000
commit81cf8de25e1cf005d705a3ab96dab777c1796d35 (patch)
treeabcef7ce2eb90e637981e0f00c53a6ce1ea22de5 /net-p2p/amule
parentadding mplayer matroska (diff)
downloadhistorical-81cf8de25e1cf005d705a3ab96dab777c1796d35.tar.gz
historical-81cf8de25e1cf005d705a3ab96dab777c1796d35.tar.bz2
historical-81cf8de25e1cf005d705a3ab96dab777c1796d35.zip
add wxGTK unicode check
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/Manifest6
-rw-r--r--net-p2p/amule/amule-1.0.7.ebuild14
-rw-r--r--net-p2p/amule/amule-1.0.8.ebuild14
-rw-r--r--net-p2p/amule/amule-1.0.9.ebuild14
4 files changed, 42 insertions, 6 deletions
diff --git a/net-p2p/amule/Manifest b/net-p2p/amule/Manifest
index 7767b16c7482..6b6f95d158bc 100644
--- a/net-p2p/amule/Manifest
+++ b/net-p2p/amule/Manifest
@@ -1,8 +1,8 @@
-MD5 ad3dd58f3b7fdb92dcd5d5a410874696 amule-1.0.8.ebuild 638
-MD5 98cb22bfd45230af61868ed9084e18c1 amule-1.0.7.ebuild 636
+MD5 b35705824eb877b18d46e48941ce6707 amule-1.0.8.ebuild 986
+MD5 0fad689d790d1b7b9a0e122135031b72 amule-1.0.7.ebuild 984
MD5 16f94954ee9abce647abbf18d645e819 ChangeLog 660
MD5 a44c56b0436befb3cb8efb8d51492b29 metadata.xml 222
-MD5 9110f7c842409657fc50c1c27c5b74d3 amule-1.0.9.ebuild 638
+MD5 3fd88b444f97a095dc14c2bbf83c3088 amule-1.0.9.ebuild 986
MD5 fde304f786a1695f27c99a35357adce7 files/digest-amule-1.0.7 65
MD5 07cafaceb13a8fba0060a3aeebd6ae51 files/digest-amule-1.0.8 65
MD5 e6eb31298986ba0891a681581659cd12 files/digest-amule-1.0.9 65
diff --git a/net-p2p/amule/amule-1.0.7.ebuild b/net-p2p/amule/amule-1.0.7.ebuild
index e573ad70f680..b90917fd7368 100644
--- a/net-p2p/amule/amule-1.0.7.ebuild
+++ b/net-p2p/amule/amule-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.7.ebuild,v 1.2 2003/10/18 17:17:26 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.7.ebuild,v 1.3 2003/10/18 22:58:12 scandium Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die
diff --git a/net-p2p/amule/amule-1.0.8.ebuild b/net-p2p/amule/amule-1.0.8.ebuild
index bc5b114b17c9..18cd85ee8cf3 100644
--- a/net-p2p/amule/amule-1.0.8.ebuild
+++ b/net-p2p/amule/amule-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.8.ebuild,v 1.2 2003/10/18 17:17:26 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.8.ebuild,v 1.3 2003/10/18 22:58:12 scandium Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4.1
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die
diff --git a/net-p2p/amule/amule-1.0.9.ebuild b/net-p2p/amule/amule-1.0.9.ebuild
index 9581f57891f4..58d0ef66a42f 100644
--- a/net-p2p/amule/amule-1.0.9.ebuild
+++ b/net-p2p/amule/amule-1.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.9.ebuild,v 1.2 2003/10/18 17:17:26 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.9.ebuild,v 1.3 2003/10/18 22:58:12 scandium Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4.1
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die