summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Kryczek <mkay@gentoo.org>2005-09-18 11:46:17 +0000
committerMarcin Kryczek <mkay@gentoo.org>2005-09-18 11:46:17 +0000
commitc89948ee68ad35554f0d45929da7be1921eb3bff (patch)
tree1f07c769ed6cfdfdf29f689155c84dfc4e61b450 /net-p2p/amule
parentFixed bug 62368. (diff)
downloadhistorical-c89948ee68ad35554f0d45929da7be1921eb3bff.tar.gz
historical-c89948ee68ad35554f0d45929da7be1921eb3bff.tar.bz2
historical-c89948ee68ad35554f0d45929da7be1921eb3bff.zip
Older version has the same problem with symlinks outside sandbox. Fixed
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog5
-rw-r--r--net-p2p/amule/Manifest6
-rw-r--r--net-p2p/amule/amule-2.0.1.ebuild11
3 files changed, 16 insertions, 6 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index ce23eba913bc..2f46ce28aa5a 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.44 2005/09/17 22:26:45 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.45 2005/09/18 11:46:17 mkay Exp $
+
+ 18 Sep 2005; <mkay@gentoo.org> amule-2.0.1.ebuild:
+ Older version has the same problem with symlinks outside sandbox. Fixed
17 Sep 2005; <mkay@gentoo.org> amule-2.0.3.ebuild:
Fixing symlinks made to files in live system (sandbox violation)
diff --git a/net-p2p/amule/Manifest b/net-p2p/amule/Manifest
index a36cb4e1d9ac..82d832fa60fa 100644
--- a/net-p2p/amule/Manifest
+++ b/net-p2p/amule/Manifest
@@ -1,13 +1,13 @@
-MD5 3fb31d7f0245fd00b7f220f197af9a43 ChangeLog 6447
+MD5 e2e5fded90d658bf727f18f9d7dfc32e ChangeLog 6575
MD5 85966639c4bc2dba5e2a625d7415a40b amule-1.2.8.ebuild 925
-MD5 e6febc40306e094cd492c779f7bdcea9 amule-2.0.1.ebuild 2104
+MD5 9dbf449f81030cb9b239e16363e09a7b amule-2.0.1.ebuild 2229
MD5 c43816a1fc4d37eccb77992e7b2468b0 amule-2.0.3.ebuild 2228
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 c4b07e9659c0417a98d3372b10b2e9f7 files/amuleweb.initd 1181
MD5 8cde6982e4b5300f4521da90ab8733d6 files/amule-2.0.0_rc7-wxgtk.patch 1293
MD5 6cfdc1b9b4a65d47e9047a8fed427889 files/amuled.confd 409
MD5 37c7ee8278a02051a68d062beba82fbc files/amuled.initd 1138
MD5 9b94153fb9594079c1df009460ece8fd files/amuleweb.confd 697
-MD5 c4b07e9659c0417a98d3372b10b2e9f7 files/amuleweb.initd 1181
MD5 6222124296125a6909963944434e0291 files/digest-amule-1.2.8 65
MD5 e875c8bb7caccbc783bbd7238b520a04 files/digest-amule-2.0.1 65
MD5 393ff0bdafbbb32d292387e1ca196737 files/digest-amule-2.0.3 65
diff --git a/net-p2p/amule/amule-2.0.1.ebuild b/net-p2p/amule/amule-2.0.1.ebuild
index 8447464fb164..44d6c03cd289 100644
--- a/net-p2p/amule/amule-2.0.1.ebuild
+++ b/net-p2p/amule/amule-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.1.ebuild,v 1.4 2005/08/26 15:21:18 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.1.ebuild,v 1.5 2005/09/18 11:46:17 mkay Exp $
inherit eutils flag-o-matic wxwidgets
@@ -22,7 +22,8 @@ DEPEND=">=x11-libs/wxGTK-2.6.0
nls? ( sys-devel/gettext )
remote? ( >=media-libs/libpng-1.2.8 )
stats? ( >=media-libs/gd-2.0.32 )
- !net-p2p/xmule"
+ !net-p2p/xmule
+ sys-apps/sed"
pkg_setup() {
export WX_GTK_VER="2.6"
@@ -35,6 +36,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -r "s:\\$\\(LN_S\\) (.*):\$\(LN_S\) ${D}/\1:g" docs/man/Makefile.in
+}
+
src_compile() {
if use amuled; then
EXTRA_ECONF="--enable-amule-daemon --enable-amule-gui"