summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-10 15:08:00 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-10 15:08:00 +0000
commitf5e858a97bbcff37ef3c52549eb4c2337e60ea0e (patch)
tree9214c31778a2b14ae2d2535492cbaeae6f505813 /net-p2p/bittornado
parentVersion bumped. (diff)
downloadhistorical-f5e858a97bbcff37ef3c52549eb4c2337e60ea0e.tar.gz
historical-f5e858a97bbcff37ef3c52549eb4c2337e60ea0e.tar.bz2
historical-f5e858a97bbcff37ef3c52549eb4c2337e60ea0e.zip
Version bumped. Closes 47055
Diffstat (limited to 'net-p2p/bittornado')
-rw-r--r--net-p2p/bittornado/ChangeLog7
-rw-r--r--net-p2p/bittornado/bittornado-0.1.4.ebuild63
-rw-r--r--net-p2p/bittornado/files/digest-bittornado-0.1.41
3 files changed, 70 insertions, 1 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index fd2be1f08faa..64df84dd28e4 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.5 2004/04/05 07:38:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.6 2004/04/10 15:08:00 mholzer Exp $
+
+*bittornado-0.1.4 (10 Apr 2004)
+
+ 10 Apr 2004; Martin Holzer <mholzer@gentoo.org> bittornado-0.1.4.ebuild:
+ Version bumped. Closes 47055
*bittornado-0.1.3 (05 Apr 2004)
diff --git a/net-p2p/bittornado/bittornado-0.1.4.ebuild b/net-p2p/bittornado/bittornado-0.1.4.ebuild
new file mode 100644
index 000000000000..da8a277c4d98
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.1.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.1.4.ebuild,v 1.1 2004/04/10 15:08:00 mholzer Exp $
+
+inherit distutils
+inherit eutils
+
+MY_PN="BitTornado"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://www.bittornado.com/"
+SRC_URI="http://e.scarywater.net/bt/download/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.0
+ !virtual/bittorrent"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/${MY_PN}-CVS"
+PIXMAPLOC="/usr/share/pixmaps/bittorrent"
+
+# Why did we do this???
+#src_unpack() {
+# unpack ${A}
+# sed -i "s:os.path.abspath(os.path.dirname(sys.argv\[0\])):\"${PIXMAPLOC}/\":" ${S}/btdownloadgui.py || die "sed failure 1"
+#}
+
+src_install() {
+ distutils_src_install
+
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ dodir ${PIXMAPLOC}
+ insinto ${PIXMAPLOC}
+ doins *.ico *.gif
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ rm ${D}/usr/bin/*gui.py
+ fi
+}
diff --git a/net-p2p/bittornado/files/digest-bittornado-0.1.4 b/net-p2p/bittornado/files/digest-bittornado-0.1.4
new file mode 100644
index 000000000000..1740174ea779
--- /dev/null
+++ b/net-p2p/bittornado/files/digest-bittornado-0.1.4
@@ -0,0 +1 @@
+MD5 c5cb7099921b31a0f0f1ef4747d43ffc BitTornado-0.1.4.tar.gz 161367