summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author <luke-jr@gentoo.org>2003-12-17 18:29:01 +0000
committer <luke-jr@gentoo.org>2003-12-17 18:29:01 +0000
commitcbd1fc83c941659c5810490f2438ad85f2904fd9 (patch)
tree3c84707e2df7da8b81ff1bb6aad5b39bc8ed0f56 /net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild
parentformerly net-p2p/bittorrent (diff)
downloadhistorical-cbd1fc83c941659c5810490f2438ad85f2904fd9.tar.gz
historical-cbd1fc83c941659c5810490f2438ad85f2904fd9.tar.bz2
historical-cbd1fc83c941659c5810490f2438ad85f2904fd9.zip
formerly net-p2p/bittorrent
Diffstat (limited to 'net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild')
-rw-r--r--net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild b/net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild
new file mode 100644
index 000000000000..e51ed6f86324
--- /dev/null
+++ b/net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-stats/bittorrent-stats-3.2.1b-r4.ebuild,v 1.1 2003/12/17 18:28:43 luke-jr Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent-stats/BitTorrent}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://bitconjurer.org/BitTorrent/${MY_P}.tar.gz"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="x86 ~ppc alpha ~sparc"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+
+mydoc="FAQ.txt README.txt LICENSE.txt"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/bittorrent-stats-${PV}.patch || die "patch failed"
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+