summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-05-01 14:46:21 +0000
committerJon Hood <squinky86@gentoo.org>2006-05-01 14:46:21 +0000
commitc931a662cd8256008794b04b5fb175f324e09561 (patch)
tree91fa9ee7de36e42bfd6212ab2eca056ea5603d25 /net-p2p/ctorrent/files
parentRemove KDat, since it is rather broken and unmaintained. Install lilo-config ... (diff)
downloadhistorical-c931a662cd8256008794b04b5fb175f324e09561.tar.gz
historical-c931a662cd8256008794b04b5fb175f324e09561.tar.bz2
historical-c931a662cd8256008794b04b5fb175f324e09561.zip
version bump, bug #131903
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'net-p2p/ctorrent/files')
-rw-r--r--net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-SHA.patch55
-rw-r--r--net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-vfat.patch16
-rw-r--r--net-p2p/ctorrent/files/digest-ctorrent-1.3.4-r36
3 files changed, 77 insertions, 0 deletions
diff --git a/net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-SHA.patch b/net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-SHA.patch
new file mode 100644
index 000000000000..322b55597b03
--- /dev/null
+++ b/net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-SHA.patch
@@ -0,0 +1,55 @@
+--- configure.ac.orig 2006-05-01 15:07:04.000000000 +0200
++++ configure.ac 2006-05-01 15:13:28.000000000 +0200
+@@ -10,16 +10,19 @@
+ AC_PROG_CC
+
+ # Checks for libraries.
+-AC_CHECK_LIB([ssl],[SHA1_Init],,
+- [AC_CHECK_LIB([crypt],[SHA1_Init],,
++AC_CHECK_HEADERS([openssl/sha.h],
+ [AC_CHECK_LIB([crypto],[SHA1_Init],,
+- [AC_CHECK_LIB([md],[SHA1_Init],,
+- [AC_DEFINE([USE_STANDALONE_SHA1],,[Define to 1 to use the Steve Reid's public-domain SHA-1 code.])])])])])
++ AC_CHECK_LIB([ssl],[SHA1_Init]))],
++ [AC_CHECK_HEADERS([sha.h],
++ [AC_CHECK_LIB([crypt],[SHA1_Init],,
++ [AC_CHECK_LIB([crypto],[SHA1_Init],,
++ [AC_CHECK_LIB([md],[SHA1_Init])])])],
++ [AC_DEFINE([USE_STANDALONE_SHA1],,[Define to 1 to use the Steve Reid's public-domain SHA-1 code.])])])
+
+ # Checks for header files.
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h memory.h netdb.h netinet/in.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h ssl/sha.h])
++AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h memory.h netdb.h netinet/in.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+--- btcontent.cpp.orig 2006-05-01 15:14:18.000000000 +0200
++++ btcontent.cpp 2006-05-01 15:15:19.000000000 +0200
+@@ -9,9 +9,9 @@
+ #else
+ #include <unistd.h>
+ #include <sys/param.h>
+-#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD) || defined(HAVE_LIBCRYPTO)
++#if defined(HAVE_SHA_H)
+ #include <sha.h>
+-#elif defined(HAVE_LIBSSL)
++#elif defined(HAVE_OPENSSL_SHA_H)
+ #include <openssl/sha.h>
+ #endif
+ #endif
+--- btfiles.cpp.orig 2006-05-01 15:15:47.000000000 +0200
++++ btfiles.cpp 2006-05-01 15:16:18.000000000 +0200
+@@ -8,9 +8,9 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <sys/param.h>
+-#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD) || defined(HAVE_LIBCRYPTO)
++#if defined(HAVE_SHA_H)
+ #include <sha.h>
+-#elif defined(HAVE_LIBSSL)
++#elif defined(HAVE_OPENSSL_SHA_H)
+ #include <openssl/sha.h>
+ #endif
+ #endif
diff --git a/net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-vfat.patch b/net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-vfat.patch
new file mode 100644
index 000000000000..102ae2462124
--- /dev/null
+++ b/net-p2p/ctorrent/files/ctorrent-1.3.4-dnh2-vfat.patch
@@ -0,0 +1,16 @@
+--- btfiles.cpp.orig Sun Jan 1 18:41:21 2006
++++ btfiles.cpp Sun Mar 19 19:54:53 2006
+@@ -170,11 +170,13 @@
+ return write(fd, &c, 1);
+ #else
+ // ftruncate() not allowed on [v]fat under linux
+- if( ftruncate(fd,length) < 0 ) {
++ int retval = ftruncate(fd,length);
++ if( retval < 0 ) {
+ char c = (char)0;
+ if(lseek(fd,length - 1, SEEK_SET) < 0 ) return -1;
+ return write(fd, &c, 1);
+ }
++ else return retval;
+ #endif
+ }
diff --git a/net-p2p/ctorrent/files/digest-ctorrent-1.3.4-r3 b/net-p2p/ctorrent/files/digest-ctorrent-1.3.4-r3
new file mode 100644
index 000000000000..91e89453caec
--- /dev/null
+++ b/net-p2p/ctorrent/files/digest-ctorrent-1.3.4-r3
@@ -0,0 +1,6 @@
+MD5 823010ec78215d476537c9eba9381cdd ctorrent-1.3.4.tar.bz2 87333
+RMD160 0cf6a89e8e29a1c3fad087e1c666941c6ecd73b9 ctorrent-1.3.4.tar.bz2 87333
+SHA256 7e2ef5d0656ac23cecd03374d9b00291a55b274c972adfe94d6f41ae3ba60c73 ctorrent-1.3.4.tar.bz2 87333
+MD5 587a062bc863c47f4ab8b816ed035e9f patchset-ctorrent-1.3.4-dnh2.diff 394735
+RMD160 3eda43626e9583e8aabadec58df973b879ea9283 patchset-ctorrent-1.3.4-dnh2.diff 394735
+SHA256 e54966def9c541bef97a08eb303e82c91af919536c06108c8582632e451da318 patchset-ctorrent-1.3.4-dnh2.diff 394735