summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-10-06 06:40:41 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-10-06 06:40:41 +0000
commitc73e67974ab7d2e6aa5a64cedc994e97d56db103 (patch)
tree1c411a3ea1de7fecbd3467ab6b68f07b622f7396 /net-p2p/dclib/dclib-0.2.20.ebuild
parentversion bump (diff)
downloadhistorical-c73e67974ab7d2e6aa5a64cedc994e97d56db103.tar.gz
historical-c73e67974ab7d2e6aa5a64cedc994e97d56db103.tar.bz2
historical-c73e67974ab7d2e6aa5a64cedc994e97d56db103.zip
version bump
Diffstat (limited to 'net-p2p/dclib/dclib-0.2.20.ebuild')
-rw-r--r--net-p2p/dclib/dclib-0.2.20.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/dclib/dclib-0.2.20.ebuild b/net-p2p/dclib/dclib-0.2.20.ebuild
new file mode 100644
index 000000000000..e9f6411eff7d
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.2.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.2.20.ebuild,v 1.1 2003/10/06 06:40:34 aliz Exp $
+
+inherit gcc eutils
+
+DESCRIPTION="Library for the Qt client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://download.berlios.de/dcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-apps/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ [ `gcc-major-version` == 2 ] && epatch ${FILESDIR}/${P}-gcc2.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}