summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-26 17:00:22 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-26 17:00:22 +0000
commitc8e11a99e70c0a6492a690e9751ea89de27bf8d7 (patch)
treeab6b6ab49575883b5135b574d0b6e416eff29bbe /net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
parentold (diff)
downloadhistorical-c8e11a99e70c0a6492a690e9751ea89de27bf8d7.tar.gz
historical-c8e11a99e70c0a6492a690e9751ea89de27bf8d7.tar.bz2
historical-c8e11a99e70c0a6492a690e9751ea89de27bf8d7.zip
Initial import, bug #317127, thank Nikoli for this job.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild')
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
new file mode 100644
index 000000000000..1871719834a4
--- /dev/null
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.1 2010/04/26 17:00:22 pva Exp $
+
+EAPI=2
+
+LANGS="be en hu ru"
+inherit qt4-r2 cmake-utils subversion
+
+DESCRIPTION="Qt4 based client for DirectConnect and ADC protocols, based on DC++ library"
+HOMEPAGE="http://eiskaltdc.googlecode.com/"
+ESVN_REPO_URI="http://${PN%pp}.googlecode.com/svn/branches/trunk/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="spell"
+
+RDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ dev-libs/openssl
+ net-libs/libupnp
+ dev-libs/boost
+ app-arch/bzip2
+ sys-libs/zlib
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # linguas
+ local langs
+ for lang in ${LANGS}; do
+ use linguas_${lang} && langs+="${lang} "
+ done
+ [[ -z ${langs} ]] && langs=${LANGS}
+
+ local mycmakeargs=(
+ "$(cmake-utils_use spell USE_ASPELL)"
+ -Dlinguas="${langs}"
+ )
+ cmake-utils_src_configure
+}