summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-06-26 17:53:01 +0000
committerJon Hood <squinky86@gentoo.org>2004-06-26 17:53:01 +0000
commit6144ea0a8e542f623c1e1109790f61e634dc5993 (patch)
tree94837707ce10848491e6ef884a7b7a7e5f8ee098 /net-p2p/gift/gift-0.11.6-r1.ebuild
parentAdded ability to install from CD. Ebuild submitted by David A. Bestor <gento... (diff)
downloadhistorical-6144ea0a8e542f623c1e1109790f61e634dc5993.tar.gz
historical-6144ea0a8e542f623c1e1109790f61e634dc5993.tar.bz2
historical-6144ea0a8e542f623c1e1109790f61e634dc5993.zip
new init script and substantial ebuild changes, #24496
Diffstat (limited to 'net-p2p/gift/gift-0.11.6-r1.ebuild')
-rw-r--r--net-p2p/gift/gift-0.11.6-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-p2p/gift/gift-0.11.6-r1.ebuild b/net-p2p/gift/gift-0.11.6-r1.ebuild
new file mode 100644
index 000000000000..847b851d4522
--- /dev/null
+++ b/net-p2p/gift/gift-0.11.6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/gift-0.11.6-r1.ebuild,v 1.1 2004/06/26 17:53:01 squinky86 Exp $
+
+inherit eutils
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network daemon"
+HOMEPAGE="http://gift.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+RESTRICT="nomirror"
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+
+RDEPEND=">=sys-libs/zlib-1.1.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+GIFTUSER="p2p"
+
+src_install() {
+ einstall \
+ giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ giftdatadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+
+ # init scripts for users who want a central server
+ insinto /etc/conf.d; newins ${FILESDIR}/gift.confd gift
+ exeinto /etc/init.d; newexe ${FILESDIR}/gift.initd gift
+
+ # add user
+ enewuser ${GIFTUSER} -1 /bin/bash /home/p2p users
+
+ touch ${D}/usr/share/giFT/giftd.log
+ chown ${GIFTUSER}:root ${D}/usr/share/giFT/giftd.log
+}
+
+pkg_postinst() {
+ einfo "First, you need to run gift-setup with your normal"
+ einfo "user account to create the giFT configuration files."
+ echo
+ einfo "Also, if you will be using the giFT init script, you"
+ einfo "will need to create /usr/share/giFT/giftd.conf"
+ einfo "This method is only recommended for users with a"
+ einfo "central giFT server."
+ echo
+ einfo "This package no longer contains any protocol plugins,"
+ einfo "please try gift-fasttrack, gift-openft, gift-gnutella"
+ einfo "for protocol support."
+ echo
+ einfo "If you encounter issues with this package, please contact"
+ einfo "us via bugs.gentoo.org rather than attempting to contact"
+ einfo "the upstream developers, as they are hesitant to provide"
+ einfo "appropriate and polite support."
+}