summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Destuynder <kang@gentoo.org>2005-09-23 21:21:32 +0000
committerGuillaume Destuynder <kang@gentoo.org>2005-09-23 21:21:32 +0000
commitaa048319966951cf1b495af180f4da6bdf9d65a1 (patch)
tree8569c7ecb8e558905f7d527e6107919da82f9a3e /net-p2p
parent* bump (diff)
downloadhistorical-aa048319966951cf1b495af180f4da6bdf9d65a1.tar.gz
historical-aa048319966951cf1b495af180f4da6bdf9d65a1.tar.bz2
historical-aa048319966951cf1b495af180f4da6bdf9d65a1.zip
version bump. waiting for twisted unmask to unmask anything.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/phxd/ChangeLog7
-rw-r--r--net-p2p/phxd/Manifest8
-rw-r--r--net-p2p/phxd/files/digest-phxd-0.1.0_pre230920051
-rw-r--r--net-p2p/phxd/phxd-0.1.0_pre23092005.ebuild52
4 files changed, 64 insertions, 4 deletions
diff --git a/net-p2p/phxd/ChangeLog b/net-p2p/phxd/ChangeLog
index 6ff799feda68..18f615cb9809 100644
--- a/net-p2p/phxd/ChangeLog
+++ b/net-p2p/phxd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/phxd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/phxd/ChangeLog,v 1.2 2005/06/27 08:17:26 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phxd/ChangeLog,v 1.3 2005/09/23 21:21:31 kang Exp $
+
+*phxd-0.1.0_pre23092005 (23 Sep 2005)
+ 23 Sep 2005; Guillaume Destuynder <kang@gentoo.org>
+ +phxd-0.1.0_pre23092005.ebuild:
+ - Version bump. has IRC compatibility support. See vivahx.com for more info.
27 Jun 2005; David Holm <dholm@gentoo.org> phxd-0.0.1_pre26062005.ebuild:
Added to ~ppc.
diff --git a/net-p2p/phxd/Manifest b/net-p2p/phxd/Manifest
index 14eff9366ca8..16b84975cbf5 100644
--- a/net-p2p/phxd/Manifest
+++ b/net-p2p/phxd/Manifest
@@ -1,5 +1,7 @@
-MD5 5d0f7811c98bed9b3daba107485520e4 ChangeLog 469
-MD5 7cd97c7cbf2e69eb743615c6bf6f17e4 metadata.xml 512
MD5 d40d5ff2d174a1598787148e68cfecf5 phxd-0.0.1_pre26062005.ebuild 1162
-MD5 5969c95ca96db4f6bc3e0716d9652c16 files/80phxd 27
+MD5 ba8ce93b008a4552f26d47d4226cdc0a phxd-0.1.0_pre23092005.ebuild 1196
+MD5 16cc25122fcfbbca18886be4c4cc4d8e ChangeLog 674
+MD5 7cd97c7cbf2e69eb743615c6bf6f17e4 metadata.xml 512
MD5 2fe81bb56f58d110daa0935da3f11992 files/digest-phxd-0.0.1_pre26062005 73
+MD5 a6c78daa4c5c9652cfbb132d52f01da7 files/digest-phxd-0.1.0_pre23092005 74
+MD5 5969c95ca96db4f6bc3e0716d9652c16 files/80phxd 27
diff --git a/net-p2p/phxd/files/digest-phxd-0.1.0_pre23092005 b/net-p2p/phxd/files/digest-phxd-0.1.0_pre23092005
new file mode 100644
index 000000000000..5a2051f85334
--- /dev/null
+++ b/net-p2p/phxd/files/digest-phxd-0.1.0_pre23092005
@@ -0,0 +1 @@
+MD5 5c8e2279623592e6be196e8d030c67c8 phxd-0.1.0_pre23092005.tar.bz2 25224
diff --git a/net-p2p/phxd/phxd-0.1.0_pre23092005.ebuild b/net-p2p/phxd/phxd-0.1.0_pre23092005.ebuild
new file mode 100644
index 000000000000..00ec07790a05
--- /dev/null
+++ b/net-p2p/phxd/phxd-0.1.0_pre23092005.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phxd/phxd-0.1.0_pre23092005.ebuild,v 1.1 2005/09/23 21:21:31 kang Exp $
+
+inherit eutils
+
+DESCRIPTION="Next generation Hotline server in python. kang's branch."
+HOMEPAGE="http://www.avaraline.net"
+SRC_URI="mirror://gentoo/phxd-0.1.0_pre23092005.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="mysql"
+
+DEPEND="dev-python/twisted
+ dev-python/twisted-web
+ mysql? ( dev-db/mysql )"
+
+RDEPEND=""
+
+pkg_postinst() {
+ enewgroup phxd || die "Failed to create phxd group"
+ enewuser phxd -1 /bin/bash /var/phxd phxd || "Failed to create phxd user"
+ chown phxd:phxd /var/phxd/files
+ chown phxd:phxd /var/phxd/chatlogs
+}
+
+src_install() {
+ cd ${WORKDIR}
+ cd phxd
+
+ insinto /etc/env.d; doins ${FILESDIR}/80phxd
+
+ dodoc INSTALL README README-kang
+ dodir /var/phxd
+
+ exeinto /var/phxd; doexe phxd
+
+ cpdirs="support shared server client"
+ for i in $cpdirs; do
+ cp -R $i ${D}/var/phxd
+ done
+ dodir /var/phxd/files
+ dodir /var/phxd/chatlogs
+
+ keepdir /var/phxd/files
+ keepdir /var/phxd/chatlogs
+ keepdir /var/phxd
+
+ insinto /var/phxd; doins config.py
+}