summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-04-10 19:26:10 +0000
committerDonny Davies <woodchip@gentoo.org>2002-04-10 19:26:10 +0000
commitb83735ebd5517cd8b5e262a63ae7ae9a27ff0803 (patch)
treef473a88a7865b97e216dd44208263063b25bbf6c /net-print
parentadd missing patch (diff)
downloadhistorical-b83735ebd5517cd8b5e262a63ae7ae9a27ff0803.tar.gz
historical-b83735ebd5517cd8b5e262a63ae7ae9a27ff0803.tar.bz2
historical-b83735ebd5517cd8b5e262a63ae7ae9a27ff0803.zip
new package contributed by steve_flack@ntlworld.com (Steve Flack).
not quite sure if this is "complete" or what. hoping for some more information from Steve.
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hpijs/files/digest-hpijs-1.0.41
-rw-r--r--net-print/hpijs/hpijs-1.0.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-print/hpijs/files/digest-hpijs-1.0.4 b/net-print/hpijs/files/digest-hpijs-1.0.4
new file mode 100644
index 000000000000..a1bec4bbef99
--- /dev/null
+++ b/net-print/hpijs/files/digest-hpijs-1.0.4
@@ -0,0 +1 @@
+MD5 e2b8d2a671fdbcd27f20092691d40bba hpijs-1.0.4.tar.gz 276833
diff --git a/net-print/hpijs/hpijs-1.0.4.ebuild b/net-print/hpijs/hpijs-1.0.4.ebuild
new file mode 100644
index 000000000000..d91ededb0fe7
--- /dev/null
+++ b/net-print/hpijs/hpijs-1.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Steve Flack <steve_flack@ntlworld.com>
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.0.4.ebuild,v 1.1 2002/04/10 19:26:09 woodchip Exp $
+
+# Though this program runs on it's own it makes no sense to run it without ghostscript
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The HP Inkjet server for Ghostscript. Provides best output for HP Inkjet Printers"
+HOMEPAGE="http://hpinkjet.sourceforge.net"
+SRC_URI="http://prdownloads.sourceforge.net/hpinkjet/${P}.tar.gz"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND} app-text/ghostscript"
+
+src_compile () {
+ econf --host=${CHOST} || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install () {
+ einstall || die
+ # fix the doc dir, it needs to have the package revision..
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}
+
+pkg_postinst () {
+ if [ "`use cups`" ] ; then
+ einfo "To use the hpijs driver with the cups spooler, you will need the .ppd file"
+ einfo "for your printer. You may obtain it from:"
+ einfo "http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "Install it in /usr/share/cups/model. After restarting cups you should be"
+ einfo "able to use the new driver"
+ else
+ einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ driver file"
+ einfo "for your printer from http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "This file should be installed in /etc/pdq/drivers"
+ fi
+}