summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-02-01 19:47:46 +0000
committerPacho Ramos <pacho@gentoo.org>2010-02-01 19:47:46 +0000
commit02a1a11e0c309ff5c57bcb10e209d02d37b905b2 (patch)
tree4bd759216a1c04a1e57b6cec92b82d75dd356b24 /net-wireless/bluez/files
parentamd64 stable, bug #299942 (diff)
downloadhistorical-02a1a11e0c309ff5c57bcb10e209d02d37b905b2.tar.gz
historical-02a1a11e0c309ff5c57bcb10e209d02d37b905b2.tar.bz2
historical-02a1a11e0c309ff5c57bcb10e209d02d37b905b2.zip
Version bump and lots of fixes
Package-Manager: portage-2.1.7.16/cvs/Linux x86_64
Diffstat (limited to 'net-wireless/bluez/files')
-rw-r--r--net-wireless/bluez/files/4.60/bluetooth-conf.d7
-rw-r--r--net-wireless/bluez/files/4.60/bluetooth-init.d31
-rw-r--r--net-wireless/bluez/files/4.60/cups-location.patch13
3 files changed, 51 insertions, 0 deletions
diff --git a/net-wireless/bluez/files/4.60/bluetooth-conf.d b/net-wireless/bluez/files/4.60/bluetooth-conf.d
new file mode 100644
index 000000000000..b0cc744415ad
--- /dev/null
+++ b/net-wireless/bluez/files/4.60/bluetooth-conf.d
@@ -0,0 +1,7 @@
+# Bluetooth configuraton file
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/net-wireless/bluez/files/4.60/bluetooth-init.d b/net-wireless/bluez/files/4.60/bluetooth-init.d
new file mode 100644
index 000000000000..111902aaeb55
--- /dev/null
+++ b/net-wireless/bluez/files/4.60/bluetooth-init.d
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/4.60/bluetooth-init.d,v 1.1 2010/02/01 19:47:46 pacho Exp $
+
+depend() {
+ after coldplug
+ need dbus localmount
+}
+
+start() {
+ ebegin "Starting Bluetooth"
+
+ udevadm trigger --subsystem-match=bluetooth
+ eend $?
+
+ if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
+ if [ -f "${RFCOMM_CONFIG}" ]; then
+ ebegin " Starting rfcomm"
+ /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
+ eend $?
+ else
+ ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
+ fi
+ fi
+}
+
+stop() {
+ ebegin "Shutting down Bluetooth"
+ eend 0
+}
diff --git a/net-wireless/bluez/files/4.60/cups-location.patch b/net-wireless/bluez/files/4.60/cups-location.patch
new file mode 100644
index 000000000000..66ed8dc22e5b
--- /dev/null
+++ b/net-wireless/bluez/files/4.60/cups-location.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.tools b/Makefile.tools
+index d9a2425..a382e05 100644
+--- a/Makefile.tools
++++ b/Makefile.tools
+@@ -122,7 +122,7 @@ EXTRA_DIST += tools/dfubabel.1 tools/avctrl.8
+
+
+ if CUPS
+-cupsdir = $(libdir)/cups/backend
++cupsdir = `cups-config --serverbin`/backend
+
+ cups_PROGRAMS = cups/bluetooth
+