summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-04-07 09:03:40 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-04-07 09:03:40 +0000
commit9d316df5380f89e71e0c5b01c3e70bc2a894826e (patch)
tree3552abf393b583c8d0164b458827529e86c4ceb7 /net-wireless/bluez/files
parentVersion bump (diff)
downloadhistorical-9d316df5380f89e71e0c5b01c3e70bc2a894826e.tar.gz
historical-9d316df5380f89e71e0c5b01c3e70bc2a894826e.tar.bz2
historical-9d316df5380f89e71e0c5b01c3e70bc2a894826e.zip
Version bump, fixed build problems with --disable{alsa,gstreamer}. Bug #260374 has already been solved in an earlier bump.
Package-Manager: portage-2.1.6.11/cvs/Linux x86_64
Diffstat (limited to 'net-wireless/bluez/files')
-rw-r--r--net-wireless/bluez/files/4.34-conditional_libsbc.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-wireless/bluez/files/4.34-conditional_libsbc.patch b/net-wireless/bluez/files/4.34-conditional_libsbc.patch
new file mode 100644
index 000000000000..e4924c79be87
--- /dev/null
+++ b/net-wireless/bluez/files/4.34-conditional_libsbc.patch
@@ -0,0 +1,39 @@
+The configure stuff is a inconsequent:
+- even if neither alsa nor gstreamer support is enabled, SBC_LIBS gets substituted by libsbc.la
+ which doesn't get build without alsa or gstreamer. Making this conditional helps.
+- ipctest needs both libipc.la and libsbc.la and fails if SBC_LIBS/SBC_CFLAGS are empty,
+ making the build conditional helps again.
+--- acinclude.m4.orig 2009-04-06 16:26:14.570780241 +0200
++++ acinclude.m4 2009-04-06 16:26:59.540779148 +0200
+@@ -330,8 +330,10 @@
+ AC_SUBST([GDBUS_CFLAGS], ['-I$(top_srcdir)/gdbus'])
+ AC_SUBST([GDBUS_LIBS], ['$(top_builddir)/gdbus/libgdbus.la'])
+
+- AC_SUBST([SBC_CFLAGS], ['-I$(top_srcdir)/sbc'])
+- AC_SUBST([SBC_LIBS], ['$(top_builddir)/sbc/libsbc.la'])
++ if (test "${alsa_enable}" = "yes" || test "${gstreamer_enable}" = "yes"); then
++ AC_SUBST([SBC_CFLAGS], ['-I$(top_srcdir)/sbc'])
++ AC_SUBST([SBC_LIBS], ['$(top_builddir)/sbc/libsbc.la'])
++ fi
+
+ AM_CONDITIONAL(SNDFILE, test "${sndfile_enable}" = "yes" && test "${sndfile_found}" = "yes")
+ AM_CONDITIONAL(NETLINK, test "${netlink_enable}" = "yes" && test "${netlink_found}" = "yes")
+--- audio/Makefile.am.orig 2009-04-06 16:47:21.240681272 +0200
++++ audio/Makefile.am 2009-04-06 17:42:27.240597715 +0200
+@@ -60,10 +60,16 @@
+
+ libipc_la_SOURCES = ipc.h ipc.c
+
++if AUDIOPLUGIN
++if SBC
++
+ noinst_PROGRAMS = ipctest
+
+ ipctest_LDADD= libipc.la @SBC_LIBS@ @GLIB_LIBS@
+
++endif
++endif
++
+ AM_CFLAGS = -fvisibility=hidden @SBC_CFLAGS@ \
+ @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
+