summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2007-03-20 01:34:16 +0000
committerStephen Klimaszewski <steev@gentoo.org>2007-03-20 01:34:16 +0000
commitb77984912fbe0bd9da6f0208ea0d9c953a68c79a (patch)
treecadd61e0d696379161b68bf09f44daceea34ed62 /net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild
parentVersion Bump. (diff)
downloadhistorical-b77984912fbe0bd9da6f0208ea0d9c953a68c79a.tar.gz
historical-b77984912fbe0bd9da6f0208ea0d9c953a68c79a.tar.bz2
historical-b77984912fbe0bd9da6f0208ea0d9c953a68c79a.zip
New upstream release
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild')
-rw-r--r--net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild
new file mode 100644
index 000000000000..4a8b38a1c478
--- /dev/null
+++ b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.3.ebuild,v 1.1 2007/03/20 01:34:15 steev Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-ng-tools/}-${PV}
+S=${WORKDIR}/${MY_P}/tools
+
+DESCRIPTION="Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards"
+HOMEPAGE="http://www.madwifi.org/"
+SRC_URI="mirror://sourceforge/madwifi/madwifi-${PV}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="!net-wireless/madwifi-old-tools
+ ${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ # format string fix from solar
+ #sed -i \
+# -e 's:err(1, ifr.ifr_name);:err(1, "%s", ifr.ifr_name);:g' \
+# ${S}/tools/athstats.c || die
+
+einfo "S=$S"
+einfo "PV=$PV"
+
+ sed -i \
+ -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "s:CFLAGS=:CFLAGS+=:" \
+ -e "s:LDFLAGS=:LDFLAGS+=:" \
+ ${S}/Makefile || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR=/usr/bin MANDIR=/usr/share/man STRIP=echo \
+ install || die "emake install failed"
+
+ dodir /sbin
+ mv "${D}"/usr/bin/wlanconfig "${D}"/sbin
+}
+
+pkg_postinst() {
+ if [ -e "${ROOT}"/etc/udev/rules.d/65-madwifi.rules ]; then
+ ewarn
+ ewarn "The udev rules for creating interfaces (athX) are no longer needed."
+ ewarn
+ ewarn "You should manually remove the /etc/udev/rules.d/65-madwifi.rules file"
+ ewarn "and either run 'udevstart' or reboot for the changes to take effect."
+ ewarn
+ fi
+}